summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67b2447..1b87ccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ pkgname=cataclysm-bn
_pkgname=Cataclysm-BN-cbn-experimental
pkgver=202201182023
_pkgver=2022-01-18-2023
-pkgrel=1
+pkgrel=2
pkgdesc="A post-apocalyptic roguelike."
#url="http://cataclysmrl.blogspot.com/"
#url="http://www.cataclysm.glyphgryph.com/"
@@ -55,12 +55,13 @@ source=("$pkgname-$_pkgver.tar.gz::https://github.com/cataclysmbnteam/Cataclysm-
"mutations-01_nerf-lightstep.patch"
"mutations-02_fix-evac3-background-visible.patch"
- "npc-01_dialogue-fixes.patch"
- "npc-02_isherwood-duplicate-mission.patch"
+ "npc-01_isherwood-update.patch"
+ "npc-02_tacoma-update.patch"
+ "npc-03_godco-update.patch"
+ "npc-04_dialogue-fixes.patch"
"recipes-01_4570-dragon-can-be-dismantled.patch"
- "terrain-02_tacoma-barn-door-position.patch"
"terrain-03_tacoma-clinic-add-missing-floor.patch"
"terrain-04_lumbermill-gasoline-not-spilled.patch"
"terrain-05_community-garden-fertilizer-not-spilled.patch"
@@ -119,10 +120,11 @@ b2sums=('c2ba9f8cf1dd9448dfc5f918d0459ae4145ade15821a3024d446b506c5f7da72bab1043
'8bb71fbec3deece7bd0f9084e20ef5853812e71e2ebcd43011f7779499cbb99c7a8bc5c618d8ef9f55e5ce54c9fc4a5f4d3167bb63f9821a68889f9f3e1386f5'
'08f4746882b927bdff6b728630cf1e04a2b79924f694ca2d841e3115c3399feb87a8d363e4d2a0f59179c109cb6be6e840f912aadd44abb0bdb35afd2838cc4d'
'ab35d6663b864449d46da4a9e1c51e11956ff4c38e16db58c831b71f7b964fc25b0283122dbc8aa0549f240f01c4a910fb5c6c82937258c6b736c05b54bcf768'
+ '24c5f9ee5553b66ac937785b3312378adbca096888b05da8b0cdc9c0586ee51e9a3754615cc03a659cfe70ba2f48f7ce0359025c816c887c7691424c685f5f96'
+ '29402b22f8d7cf4c038b938aa92bbda9993751cba3e0cff05f9206651ba4ded44cfb9c18a06647c44b81398863aeb7c45e771972135fc804a08e5f45add40812'
+ 'e51bf3f26ed46d3572959a33cee680728dfff361195d1594eabe609d0e741d63c641c9423c33ebadf305a6b3443f348db2bf7120c20c5f5f77f38864e1323786'
'adcf0b46ad57390488b3932910fba5a5be8152f91b45864bf078a2b8d92dc89e9944c320dafb7a0d4786e1fce48bedea714d671feefe565ffbbb74baca21d98e'
- '339e48c2ce8d98852445839a71217a62af47af541c9e7573f21112c8b0bd5409b676774d2efd8665fe7f4cb5e6251467f77b9d9fad43a4c1fd61b405ae5e9831'
'71768899e631c5293d5fb8bcb237ca54f880913b6400d445c8a0322cb69801fe85b94b1293306e2f33fac6067cbd892c4665b9563bdc9ff4df5be245c7e7108f'
- 'ce0dd5121e814e0fcd79d68362c80a83bfe70f970be9d5d6f6fe5f6a56ed3f041be4d560aaf02225c3ce7c457dc63bc3adf0709d4b89a81c18184ff5341eb5d3'
'b8a64accada87ee5be989c5307805610c9b5c0327bc107aab237ac3225dd9e4c51b6c79a2a7de15fe187d3c32d7cbe1c462f9b0e9fb5d5a55a74236c7061e96e'
'85aeb5920ee5879848be4057324153a077fe907bed527ed8f9b80a3c5ee1ef64786f63ee2999f5ba74e80a43e99ded3280ce27759c1f7b73259a6e2b5e584aa8'
'58a94409205f7b670ab5745b8cbc234a38efd6a6217cef4efb7e397f091092e3e0c7790706b0a42accaa83d7509b8e244a98b9f0ba78349ee85f3164745c3501'
@@ -267,14 +269,18 @@ prepare() {
# # npc fixes
echo "Applying NPC fixes"
+ # Port over updates to Isherwood Farm
+ patch -Np1 -i "$srcdir"/npc-01_isherwood-update.patch
+
+ # Port over updates to Tacoma Commune
+ patch -Np1 -i "$srcdir"/npc-02_tacoma-update.patch
+
+ # Port over updates to New England Church Community
+ patch -Np1 -i "$srcdir"/npc-03_godco-update.patch
+
# Assorted typos in NPC dialogue.
# Fix Jack Isherwood mission listing 10 jars, when it is actually 20.
- patch -Np1 -i "$srcdir"/npc-01_dialogue-fixes.patch
-
- echo "Applying NPC fixes"
- # Jesse Isherwood's second mission is defined twice for some reason.
- # Remove the version that is just a mashup of mission one and two.
- patch -Np1 -i "$srcdir"/npc-02_isherwood-duplicate-mission.patch
+ patch -Np1 -i "$srcdir"/npc-04_dialogue-fixes.patch
# # recipe fixes
@@ -285,10 +291,6 @@ prepare() {
# # terrain and overmap fixes
echo "Applying terrain and overmap fixes"
- # Fix tacoma barn doors being placed in the same spot twice:
- # This enables the southeast barn door to be placed properly.
- patch -Np1 -i "$srcdir"/terrain-02_tacoma-barn-door-position.patch
-
# Fix missing floor in the tacoma clinic:
# The hospital is still a mess. :/
patch -Np1 -i "$srcdir"/terrain-03_tacoma-clinic-add-missing-floor.patch