summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d95348..843e84f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _pkgname=firefox
pkgname=${_pkgname}-esr
pkgver=78.7.1
_pkgver=${pkgver}esr
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
@@ -47,6 +47,7 @@ source=(
"https://archive.mozilla.org/pub/$_pkgname/releases/$_pkgver/source/$_pkgname-$_pkgver.source.tar.xz"{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
rust_1.48.patch.gz
+ rust_1.50.patch
$pkgname.desktop
distribution.ini
mozconfig.in
@@ -61,6 +62,7 @@ b2sums=('c0c90488ef9727363f03707c3d1e83ab5965a32775db9e6832883b94f265a3d95bb4686
'SKIP'
'e4cf5d0ddd2c7271f1723b5c313f0aa8a7bf2242fb301ceba1ab5a4dca655ca7b9461d0aaebe5eaccf84b2f7a4c4199cbb0c18eab2bdaff273fcb730ec27219e'
'3eba6b3d45c52cbc708e4abdcc581aad3a6a75ed335a29e19092cb225b88f1b86457ed03853d841615f2fdb2678b49e9b7d2b3a65dff387cd81959e7e5cc4d88'
+ '9677fac5dad81eaaca7514906ba58e81dacf2ccd68345eca66bb1c62a679341a75cefd92c4733256719d24264a19be573d3a5a3eb6ee99bc0fae062e2471dd4c'
'1c3af4cc5199cf7b9f3aad9ceab98b3e8a3dc0d38f50896ed2f32ac648f1e904a1cdda5da559964885989edbfab4c4bf65448e9a0f71d946c77ec0ab5a6aff4c'
'877eda442eb4730600dccf209a6e961ad3122ab456bbfda4ff041e8493ebaaf96224ac218360931259ff4214482f6bf65b3a3052f977ade1a274f38ffd859535'
'8502bac792b4b80522bd143a6d6a274017844f1c5a0261e8b391ce64ebf46e13e0cad912518e3feb0c2e8d481c413ea74759d2813332fece48d395bbe17bef0f'
@@ -82,6 +84,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1663715
patch -Np1 -i ../rust_1.48.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1684261
+ patch -Np1 -i ../rust_1.50.patch
+
if [ "${_modclang}" != "1" ]; then
# Apply gcc pgo patches
patch -p0 $srcdir/${_pkgname}-${pkgver}/security/sandbox/linux/moz.build $srcdir/arc4_enable-pgo-for-gcc.patch