summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea322a9..c3d5a6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Arch version patch script does not apply consistently
# Arch version lacks ath9k, greysky2, and raid6 patches
# Arch version lacks ck patches
-# Arch version allows SM3 and SM4
+# Arch version allows SEED, SM3, SM4, and Streebog
# Arch version is 300 Hz
# Arch version supports Intel ME
# Arch version is not configured for openrc
@@ -17,11 +17,11 @@
pkgbase=linux-ck
_majver=5.0
-_minver=5
+_minver=7
pkgver=${_majver}.${_minver}
-_ckpatchversion=1
-_ckpatch="patch-${_majver}-ck${_ckpatchversion}"
_gcc_more_v='20180509'
+_ckpatchversion=1
+_ckpatch="patch-5.0-ck${_ckpatchversion}"
_srcname=linux-${pkgver}
pkgrel=1
url='https://kernel.org'
@@ -31,13 +31,11 @@ license=('GPL2')
makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
conflicts=('linux-libre')
options=('!strip')
-source=(https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz
- https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.sign
- #http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
- ${_ckpatch}.patch
+source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
+ remove-excess-ck-extraversion.patch
+ http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-netfilter-nf_tables-fix-set-double-free-in-abort-pat.patch
ath9k-regdom-hack.patch
raid6-default-algo.patch
config.x86_64 # the main kernel config files
@@ -45,22 +43,21 @@ source=(https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('5fbd807bf2aa0a80a0bf165692d89aaf3463d03043419b0a9b104f55f12c94d0'
+sha256sums=('16e177662b9fc7255bfc51018513979f6effcbe52e459c543aa83a5b15ef54ec'
'SKIP'
- '1d8d8963d44aa8aeedc5a2ee531e197b3b51659772b871ccdd2d5dafed83f52b'
+ '2a551169f8cbb424900372fe698ae9003fbcad3614a46ca3f56b103f9c1ea763'
+ '661f64bbd8bf49afcc7c760c4148b2e2108511a1eadcae917cfe6056a83d8476'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
- '87e88d199d8e9beb89d8e5f7ce6a4bf8db18ccec169323c9b6fda563719d76ba'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
'0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
- '15cc348dc4fb5a8babae39466bc0072689dd4ada87ae1208a85c4915d1484cdd'
+ '06051cacda9d841ffd9f24eb8dabd2fcf80fbc296e002248cc9bc70350c512eb'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- '8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
_kernelname=${pkgbase#linux}
@@ -75,9 +72,14 @@ prepare() {
# Hotfixes
# msg2 "Applying hotfixes"
+ # ck hotfixes
+ msg2 "Applying ck patch hotfixes"
+ patch -p1 -i ../remove-excess-ck-extraversion.patch "$srcdir/${_ckpatch}"
+ sed -i '/-CFLAGS/ s/$/ \$(LIBELF_FLAGS)/' "$srcdir/${_ckpatch}"
+
# ck patch
msg2 "Applying ck patch"
- patch -p1 -i ../${_ckpatch}.patch
+ patch -F 3 -Np1 -i ../${_ckpatch}
# graysky2 gcc patch
msg2 "Applying graysky2 cpu patch"
@@ -87,10 +89,6 @@ prepare() {
msg2 "Applying disallow-unpriv-clone-newuser patch"
patch -p1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- # 0002-netfilter-nf_tables-fix-set-double-free-in-abort-pat.patch
- msg " Applying nftables-double-free patch"
- patch -p1 -i ../0002-netfilter-nf_tables-fix-set-double-free-in-abort-pat.patch
-
# Ignore ath9k eeprom patch
msg2 "Applying ath9k patch"
patch -p1 -i ../ath9k-regdom-hack.patch