summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 49 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01ce823..9e3f6f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,24 @@
# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
# Maintainer (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Aqua-sama <aqua@iserlohn-fortress.net>
# Contributor (Arch): Daniel Micay <danielmicay@gmail.com>
# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
# Contributor (Arch): Thomas Baechler <thomas@archlinux.org>
+# # I maintain this because:
+# Parabola version patch script does not apply consistently
+# Parabola version lacks ck ath9k and greysky2 patches
+# Parabola version allows SM3 and SM4
+# Parabola version is 300 Hz
+# Parabola version supports Intel ME
+# Parabola version is not configured for openrc
+# Parabola version builds docs using python and graphviz
+# Parabola version is out-of-date
+# Parabola version disables modules for components that lack free firmware
+
pkgbase=linux-libre-hardened-ck
-_majver=4.18
-_minver=5
+_majver=4.19
+_minver=8
_pkgver=${_majver}.${_minver}
_gnumajver=${_majver}-gnu
_gnupkgver=${_pkgver}-gnu
@@ -14,23 +26,22 @@ _hardenedver=a
_NUMAdisable=y
_ckpatchversion=1
_ckpatchname="patch-${_majver}-ck${_ckpatchversion}"
-_jcpatchversion=1
+_jcpatchversion=2
_gcc_more_v='20180509'
_srcname=linux-${_majver}
pkgver=${_pkgver}.${_hardenedver}
-pkgrel=2
-conflicts=('linux-hardened-ck')
+pkgrel=1
url='https://github.com/anthraxx/linux-hardened'
#url='http://ck.kolivas.org/patches/'
arch=('x86_64')
license=('GPL2')
makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
+conflicts=('linux-hardened-ck')
options=('!strip')
source=(https://linux-libre.fsfla.org/pub/linux-libre/releases/${_gnumajver}/linux-libre-${_gnumajver}.tar.xz{,.sign}
https://linux-libre.fsfla.org/pub/linux-libre/releases/${_gnupkgver}/patch-${_gnumajver}-${_gnupkgver}.xz{,.sign}
https://github.com/anthraxx/linux-hardened/releases/download/${_pkgver}.${_hardenedver}/linux-hardened-${_pkgver}.${_hardenedver}.patch{,.sig}
patch-${_majver}-ck${_ckpatchversion}-jcmod${_jcpatchversion}.patch
- Fix_MuQSS_full_dynticks_build.patch::https://github.com/ckolivas/linux/commit/abb4fd30fa127a0e8178b975343eb01713bc2b18.patch
#http://ck.kolivas.org/patches/4.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatchname}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
ath9k-regdom-hack.patch
@@ -38,24 +49,20 @@ source=(https://linux-libre.fsfla.org/pub/linux-libre/releases/${_gnumajver}/lin
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
-
- increase-timeout-in-lspcon_wait_mode.patch
)
-sha256sums=('55ddf20702311cf3e32127135a38cb272313679962e8a798c108b01cadaeca4f'
+sha256sums=('d06d7a0d59a96ab04e7af63244627d1d5aa2d99db84f81f559f0f8e7e58f94c8'
'SKIP'
- 'ad530ad0158e96bd18da455b6d08193ac7ae5d025787a2b2aa0c09a9927b360b'
+ 'ac7fd6ede3613a024cbecb9aa421dd22d0ea7a6c201280c6eb22c812fbae1067'
'SKIP'
- 'a06238ea0ce66d090fa899d6951c9d40fa993c7b4975088dded2c1e660c1ff69'
+ '6e36f941f608d6cca54f81efc661ea91eb6fc69c58d0dbbbe57d455bb5803f2b'
'SKIP'
- 'f00cfe3d497254853793d3aa751f5d19d81ced54504a56f247c03908eee230d1'
- '6e1f3cc3eb9a1e30a69ef1999f9aa6ad7f2f9fe4af7ba5dabe25d4ff19ee6740'
+ 'c7e090301b6fb3d6f320aeaee6747077ed616ccaf3d22d0d5937d5ea5116ffd8'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
- '70de5aec8c2139ceb1f5098cfbcfcff2cc54cb78722d01ba61c700d86765e064'
+ 'd3aba22671ca554c92406e30620a2ce3fb6e25297208e7a358d4cb7564f528d8'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '0fa6899b57d32988b70050f1a67f435936273ce1aa98575271d564ccfaf45f77')
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'65EEFE022108E2B708CBFCF7F9E712E59AF5F22A' # Daniel Micay
@@ -73,8 +80,7 @@ prepare() {
patch -Np1 < ../patch-${_gnumajver}-${_gnupkgver}
# Hotfixes
- msg2 "Applying hotfixes"
- patch -p1 -i ../increase-timeout-in-lspcon_wait_mode.patch
+ # msg2 "Applying hotfixes"
# linux hardened patch
msg2 "Applying hardened patch"
@@ -92,20 +98,21 @@ prepare() {
msg2 "Applying ck patch"
patch -p1 -i ../patch-${_majver}-ck${_ckpatchversion}-jcmod${_jcpatchversion}.patch
- # ck hotfix
- msg2 "Applying ck Fix_MuQSS_full_dynticks_build hotfix"
- patch -p1 -i ../Fix_MuQSS_full_dynticks_build.patch
-
msg2 "Setting version..."
sed -e "/^EXTRAVERSION =/s/=.*/= .${_hardenedver}/" -i Makefile
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
+ echo "-libre$_kernelname" > localversion.20-pkgname
msg2 "Setting config..."
- cp ../config.x86_64 .config
+ # we are in src/linux-x.yy.zz, looking for a config next to the pkgbuild
+ #if [ -f ${SRCDEST}/config.libre-hardened-ck.previous ]; then
+ # cp ${SRCDEST}/config.libre-hardened-ck.previous .config
+ #else
+ cp ../config.x86_64 .config
+ #fi
### Optionally disable NUMA for 64-bit kernels only
# (x86 kernels do not support NUMA)
@@ -124,10 +131,25 @@ prepare() {
fi
make olddefconfig
-
+
make menuconfig
make -s kernelrelease > ../version
+
+ # workaround for make -s kernelrelease not applying
+ # localversion to version when changed using menuconfig
+ grep -Po '(?<=CONFIG_LOCALVERSION=").*(?=")' .config > ../localversion
+ echo "$_pkgver" > ../version.temp
+ echo ".$_hardenedver" >> ../version.temp
+ cat "localversion.10-pkgrel" >> ../version.temp
+ cat "localversion.20-pkgname" >> ../version.temp
+ cat ../localversion >> ../version.temp
+ cat ../version.temp | tr -d "\n" > ../version
+
+ # back up the config
+ #msg2 "Backing up config..."
+ #cp .config ${SRCDEST}/config.libre-hardened-ck.previous
+
msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
}
@@ -146,6 +168,7 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
@@ -153,7 +176,6 @@ _package() {
install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
@@ -263,11 +285,11 @@ _package-headers() {
strip -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
-
msg2 "Fixing permissions..."
chmod -Rc u=rwX,go=rX "$pkgdir"
}