summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2021-12-20 10:36:36 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2021-12-20 10:36:36 -0800
commitd5838c31695e8f5dd919c3f9dfa3315a5122373e (patch)
treec20b147caa7a048bc028ac90d1b3c7fc95a9ba70 /PKGBUILD
parentRebuild for icu 70.1 (diff)
download0ad-d5838c31695e8f5dd919c3f9dfa3315a5122373e.tar.xz
Rebuild for python 3.10 and boost 1.78
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cf4546..8a50435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=0ad
pkgver=a25.b
_pkgver=0.0.25b-alpha
-pkgrel=2
+pkgrel=3
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game"
arch=('x86_64')
url="https://play0ad.com/"
@@ -18,14 +18,23 @@ depends=('0ad-data' 'binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'lib
'libxml2' 'openal' 'sdl2' 'wxgtk3' 'zlib' 'libgl' 'glu' 'fmt'
'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'nspr' 'libsodium')
makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust')
-source=("https://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz")
-b2sums=('674d69d625137709a186f9273607dc353fc99aea68ef3f2ea5031dbe2f684176910d757c3f03c7fbdac475d30708be448b71f5020d27a65c346bf147223bcb9d')
+source=("https://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz"
+ "python-3.10.patch")
+b2sums=('674d69d625137709a186f9273607dc353fc99aea68ef3f2ea5031dbe2f684176910d757c3f03c7fbdac475d30708be448b71f5020d27a65c346bf147223bcb9d'
+ '6b6853eacbeadfe7e95382c97572c60b1838d5f4b0b925c2bb977be76db6a0a2ac97376089a42fca6a7956319b69c56ec0d2fb59a1114002d708486582de346d')
+
+prepare() {
+ patch -d $pkgname-$_pkgver -p1 < python-3.10.patch # Fix spidermonkey build with Python 3.10
+}
build() {
cd "$pkgname-$_pkgver/build/workspaces"
# rust is prone to OOM, use 1 thread per 2GB ram
- #export MAKEFLAGS="-j32"
+ export MAKEFLAGS="-j32"
+
+ # More threads
+ #sed -i 's/JOBS=${JOBS:="-j2"}/JOBS=${JOBS:="-j32"}/' update-workspaces.sh
# -fPIE and -pie break compilation
# -flto=auto and -flto=1 break compilation since a24.b