summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09e11f2..98e067d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,16 +40,19 @@ build() {
# rust is prone to OOM, use 1 thread per 2GB ram
#export MAKEFLAGS="-j32"
-
- # More threads
- #sed -i 's/JOBS=${JOBS:="-j2"}/JOBS=${JOBS:="-j32"}/' update-workspaces.sh
+
+ # Disable hardcoded extra threads on update-workspaces stage
+ sed -i 's/JOBS=${JOBS:="-j2"}/#JOBS=${JOBS:="-j2"}/' update-workspaces.sh
+
+ # Set threads on update-workspaces stage to $MAKEFLAGS
+ export JOBS=${JOBS:="$MAKEFLAGS"}
# -fPIE and -pie break compilation
# -flto=auto and -flto=1 break compilation since a24.b
export CFLAGS="$CFLAGS -O3 -fstack-protector-all -fPIC"
export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -fPIC"
- ./update-workspaces.sh $MAKEFLAGS \
+ ./update-workspaces.sh \
--without-pch \
--bindir=/usr/bin \
--libdir=/usr/lib/0ad \