summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d7de6d..1ddfdd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
_target=arm-linux-gnueabi
pkgname=$_target-gcc
-pkgver=9.2.0
+pkgver=9.3.0
_islver=0.22
-pkgrel=2
+pkgrel=1
pkgdesc='The GNU Compiler Collection - cross compiler for ARM target'
arch=(x86_64 i686 armv7h aarch64)
url='https://gcc.gnu.org/'
@@ -19,7 +19,7 @@ makedepends=(gmp mpfr)
options=(!emptydirs !strip)
source=(https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
http://isl.gforge.inria.fr/isl-$_islver.tar.xz)
-b2sums=('41a5e148f9a6857d6599679964c203533f76f330ad527fbe7c5e746d78f6f6f6d6d0f330a67cb1e794e155be8d1cd6e986bcc8a116d620dca410b78f0bcdd453'
+b2sums=('21efb1432aefad5ed9b9b395e88ef2adfda3a8ea6e3e808cd151da6e66df9fed1bafdc8b8ff055d4b2272ac786d8b7ddc4293bb6b51c55c40a261a0eda0e7cb4'
'SKIP'
'1cb2125761adec02d9f337e8730faa5bc3a4e63cb7d968f7f4de3a3360b1f9be6caf6a27031f02df1ebe149fb70b6a32bdddbe8ae03032b8ff366f4eac274483')
validpgpkeys=(33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com>
@@ -74,21 +74,23 @@ build() {
--with-libelf \
--enable-gnu-indirect-function
- make $MAKEFLAGS all-gcc
+ make all-gcc
}
package() {
- cd gcc-build
-
- make DESTDIR="$pkgdir" install-gcc
+ make -C gcc-build DESTDIR="$pkgdir" install-gcc
# strip target binaries
- find "$pkgdir"/usr/lib/gcc/$_target/ -type f -and \( -name \*.a -or -name \*.o \) -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
+ find "$pkgdir"/usr/lib/gcc/$_target/ \
+ -type f -and \( -name \*.a -or -name \*.o \) \
+ -exec $_target-objcopy -R .comment -R .note -R .debug_info -R .debug_aranges \
+ -R .debug_pubnames -R .debug_pubtypes -R .debug_abbrev -R .debug_line \
+ -R .debug_str -R .debug_ranges -R .debug_loc '{}' \;
# strip host binaries
- find "$pkgdir"/usr/bin/ "$pkgdir"/usr/lib/gcc/$_target/ -type f -and \( -executable \) -exec strip '{}' \;
+ find "$pkgdir/usr/bin/" "$pkgdir/usr/lib/gcc/$_target/" -type f \
+ -and \( -executable \) -exec strip '{}' \;
# Remove files that conflict with host gcc package
- rm -r "$pkgdir"/usr/share/man/man7
- rm -r "$pkgdir"/usr/share/info
+ rm -r "$pkgdir/usr/share/"{man/man7,info}
}