summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..68ed68e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer (AUR): Harvey <harv@gmx.de>
+
+# # I maintain this because:
+# I use it and it is not in an official repo
+# AUR version uses md5sum and cluttered if clause
+
+license=('GPL' 'custom:Brother')
+arch=('i686' 'x86_64')
+pkgname=brscan4
+pkgver=0.4.8_1
+pkgrel=1
+pkgdesc="SANE drivers from Brother for brscan4 compatible models"
+depends=('sane' 'libusb-compat')
+group=('non-free')
+url="http://support.brother.com"
+install=brscan4.install
+
+ if [ "$CARCH" == "x86_64" ]; then
+ pkg="dlf006648/${pkgname}-${pkgver/_/-}.x86_64.rpm"
+ pkg_sha256sum="cd61be4fab254cc7c8cfcc82c19ddf2ef1fe91bfce493be62b5946f191bbcdad"
+ else
+ pkg="dlf006647/${pkgname}-${pkgver/_/-}.i386.rpm"
+ pkg_sha256sum="ff0254519a9b421e1d493fbcffefb992d6689b105e48ba1dd561cf48832cb72a"
+ fi
+
+source=("https://download.brother.com/welcome/$pkg"
+ "http://www.brother.com/agreement/English_sane/agree.html"
+ mk-udev-rules)
+sha256sums=($pkg_sha256sum
+ '3434bca1936d6a5fd6afd810cde7e1876dd4d1496722b09af180278480f464f2'
+ '2ca808c50a255e90902cfb6622964dc71c863cc085763fd918e5a795450bb73f')
+
+build() {
+ cd "$srcdir"
+ umask 022
+ mkdir -p etc/udev/rules.d
+ ./mk-udev-rules opt/brother/scanner/brscan4/{Brsane4.ini,models4/*.ini} > etc/udev/rules.d/40-$pkgname.rules
+}
+
+package() {
+ cp -r $srcdir/etc $pkgdir
+ cp -r $srcdir/opt $pkgdir
+ cp -r $srcdir/usr $pkgdir
+ install -D -m644 $srcdir/agree.html $pkgdir/usr/share/licenses/$pkgname/LICENSE.html
+ [ "$CARCH" = "x86_64" ] && mv $pkgdir/usr/lib64 $pkgdir/usr/lib
+ # move the links to the right direction
+ cd $pkgdir/usr/lib/sane
+ ln -sf libsane-brother4.so.1.0.7 $pkgdir/usr/lib/sane/libsane-brother4.so.1
+ ln -sf libsane-brother4.so.1 $pkgdir/usr/lib/sane/libsane-brother4.so
+}