summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2021-10-29 18:01:32 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2021-10-29 18:01:32 -0700
commit444181f77cb649760c3099d9b96c8f863a8f8ddf (patch)
tree3e9e1e8c44a208c342fc919de1a24081739db884 /PKGBUILD
parentFix .50bmg ammo ordering (diff)
downloadcataclysm-bn-444181f77cb649760c3099d9b96c8f863a8f8ddf.tar.xz
Updated to 2021-10-29-1727
Reorganize patches into categories. Add patch to allow followers to eat from the basecamp stocks from farther away. -Reduces NPCs being prone to starve on large camps. Temporarily revert the book changes commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD346
1 files changed, 215 insertions, 131 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f70d245..b005242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,9 @@ pkgbase=cataclysm-bn
pkgname=(cataclysm-bn cataclysm-bn-tiles)
pkgname=cataclysm-bn
_pkgname=Cataclysm-BN-cbn-experimental
-pkgver=202110161440
-_pkgver=2021-10-16-1440
-pkgrel=2
+pkgver=202110291727
+_pkgver=2021-10-29-1727
+pkgrel=1
pkgdesc="A post-apocalyptic roguelike."
#url="http://cataclysmrl.blogspot.com/"
#url="http://www.cataclysm.glyphgryph.com/"
@@ -30,42 +30,53 @@ source=("$pkgname-$_pkgver.tar.gz::https://github.com/cataclysmbnteam/Cataclysm-
"cataclysm-bn-tiles.desktop"
"icon_128x128.png"
- "0.F_backport-tacoma-barn-door-position.patch"
- "0.F_backport-make-firestation-shelter-wells-npc-drinkable.patch"
- "0.F_backport-radio-can-use-ups.patch"
-
- "0001-quiverfull-house-correct-stairs.patch"
- "0002-ankle-ammo-pouch-is-not-a-backpack.patch"
- "0003-inconsistent-ammo-names.patch"
- "0004-tacoma-clinic-add-missing-floor.patch"
- "0005-lumbermill-gasoline-not-spilled.patch"
- "0006-community-garden-fertilizer-not-spilled.patch"
- "0008-npc-can-use-more-bionics.patch"
- "0009-22-casings-can-stack.patch"
- "0010-4570-dragon-can-be-dismantled.patch"
- "0011-add-missing-mre.patch"
- "0012-fix-doors-for-npcs.patch"
- "0013-fix-20x66mm-loudness.patch"
- "0014-portable-generator-engine.patch"
- "0015-normalize-drone-volume.patch"
- "0016-medical-zombies-called-zombies.patch"
- "0017-nerf-lightstep.patch"
- "0018-rehide-redacted.patch"
- "0019-derelict-shed-is-s.patch"
- "0020-hk46-is-milspec.patch"
- "0021-foldable-bottle-is-container.patch"
- "0022-fix-evac3-background-visible.patch"
- "0023-fix-rubbersplosion.patch"
- "0024-ammo-order-fix.patch"
- "0026-fix-brioche-cooking-time.patch"
- "0027-fix-missing-ammo-frag-effects.patch"
- "0028-fix-food-materials.patch"
- "0029-fix-survivor-fingerless-gloves-warmth.patch"
- "0031-vacutainer-is-not-a-weapon.patch"
- "0032-shears-use-light-battery.patch"
- "0033-add-missing-price-postapoc.patch"
- "0034-fix-reloaded-50bmg.patch"
+ "ammo-01_inconsistent-ammo-names.patch"
+ "ammo-02_fix-20x66mm-loudness.patch"
+ "ammo-03_fix-reloaded-50bmg.patch"
+ "ammo-04_fix-missing-ammo-frag-effects.patch"
+ "ammo-05_22-casings-can-stack.patch"
+ "ammo-10_ammo-order-fix.patch"
+ "armor-01_ankle-ammo-pouch-is-not-a-backpack.patch"
+ "armor-02_fix-survivor-fingerless-gloves-warmth.patch"
+
+ "bionics-01_npc-can-use-more-bionics.patch"
+
+ "foods-01_fix-food-materials.patch"
+
+ "itemgroups-01_hk46-is-milspec.patch"
+ "itemgroups-02_add-missing-mre.patch"
+
+ "monsters-01_medical-zombies-called-zombies.patch"
+
+ "mutations-01_nerf-lightstep.patch"
+ "mutations-02_fix-evac3-background-visible.patch"
+
+ "recipes-01_fix-brioche-cooking-time.patch"
+ "recipes-02_4570-dragon-can-be-dismantled.patch"
+
+ "terrain-01_quiverfull-house-correct-stairs.patch"
+ "terrain-02_tacoma-barn-door-position.patch"
+ "terrain-03_tacoma-clinic-add-missing-floor.patch"
+ "terrain-04_lumbermill-gasoline-not-spilled.patch"
+ "terrain-05_community-garden-fertilizer-not-spilled.patch"
+ "terrain-06_fix-doors-for-npcs.patch"
+ "terrain-07_rehide-redacted.patch"
+ "terrain-08_derelict-shed-is-s.patch"
+ "terrain-09_make-firestation-shelter-wells-npc-drinkable.patch"
+
+ "tools-01_foldable-bottle-is-container.patch"
+ "tools-02_vacutainer-is-not-a-weapon.patch"
+ "tools-03_shears-use-light-battery.patch"
+ "tools-04_normalize-drone-volume.patch"
+
+ "vehicles-01_portable-generator-engine.patch"
+
+ "etc-01_fix-rubbersplosion.patch"
+ "etc-02_add-missing-price-postapoc.patch"
+ "etc-03_revert-book-revamp.patch"
+
+ "jc_radio-can-use-ups.patch"
"jc_ammo-loudness-ap-times-2.patch"
"jc_allow-bio-firestarter-on-smoker.patch"
"jc_stop-non-faction-npc-sleep-depirvation.patch"
@@ -74,6 +85,7 @@ source=("$pkgname-$_pkgver.tar.gz::https://github.com/cataclysmbnteam/Cataclysm-
"jc_allow-hacker-laptop.patch"
"jc_restore-removed-traits.patch"
"jc_more-military-base-overmap.patch"
+ "jc_npc-eat-from-further-camp.patch"
"custom.patch"
@@ -82,44 +94,45 @@ source=("$pkgname-$_pkgver.tar.gz::https://github.com/cataclysmbnteam/Cataclysm-
"cataclysm-dda-soundpack_jcsoundpack.tar.xz::https://library.iserlohn-fortress.net/cataclysm-dda-soundpack_jcsoundpack.git/snapshot/cataclysm-dda-soundpack_jcsoundpack-master.tar.xz"
"cataclysm-dda-musicpack_coag-musicpack.tar.xz::https://library.iserlohn-fortress.net/cataclysm-dda-musicpack_coag-musicpack.git/snapshot/cataclysm-dda-musicpack_coag-musicpack-master.tar.xz"
)
-b2sums=('28d01fe9a265419ad941d4ad2ca4cd1a5aafdc2e46dc1d734b718a60e3039e303f8c6b42d437a4d5a37731457863d34ebca9e2decffafba41697ca15fd4f1883'
+b2sums=('89d4382b933e4e37498036d79d64ee94b5422110606b7bc299a22f0b885caa30580f082a403e6fb3b642ebb7a1ab0a81f3769f36d37321fcac8dc62944898c1f'
'069ecde58859b3d44cd687c4b6e718610cefb693ff86e66f199ebfb1b3072023ad2b6f0c28e27ef9c1ce4997f6a5b2ca0d45046996b3ff35a4aeaeb1a7cf9421'
'ad88bc6c1e3c8183a313b5eec42f98d6956afea349feff34a86e4536c9921fa99d2594282caf27de8ebb7ffb56376ed2e76d572227bfd6d8173c7bb1f01e23b8'
'6f70e90359a14e4839d9a2683debb88850e5dd387add911ad68fd87e5512cfcdd435da63e1e370358153673fd5a72a9b1e9c94f1979edb7948b4da8c82407bad'
- 'ce0dd5121e814e0fcd79d68362c80a83bfe70f970be9d5d6f6fe5f6a56ed3f041be4d560aaf02225c3ce7c457dc63bc3adf0709d4b89a81c18184ff5341eb5d3'
- '2cdcf9ab03eb92f384caf1a2d90f82c75f880cb6286811e83217c883e421c116e7844ca193a010dc35e12eec46ede3663171a2f45f660ef5a8be95c474f61bfc'
- '51b1324506179f7fadd8bc187eb8db939494483597b0b7b63909cec66f4e94b27888ccfa926bbd2ff8b0e80108ecc373118c202a177fc2ebd4f5231f87f09a83'
- '8232c6a10fd1f608304982ae7f03eb8afc663be76cdc00aee46ecb58de838e21fdc8673841266ccd00153263f7b15b59dcd1fc6ece86834509d7ccb2cacf08fa'
- '025213998583972e7551bd7bd7376ab65857e28d4338fab60ae792a6b3bd48983aec77e5143baaa63d4f3feb7cd590c4bded529c410e4d18f2b8c5813f25daa3'
'34dacfc4f338b68ecbb449e4726dc77a6876aae1c4ac31e0df4526a4df237d43ff3dcdd1d77d9266fb74d96f36b36fb93bbf1992e827504a313fdd1f3bfaf0ed'
- 'b8a64accada87ee5be989c5307805610c9b5c0327bc107aab237ac3225dd9e4c51b6c79a2a7de15fe187d3c32d7cbe1c462f9b0e9fb5d5a55a74236c7061e96e'
- '85aeb5920ee5879848be4057324153a077fe907bed527ed8f9b80a3c5ee1ef64786f63ee2999f5ba74e80a43e99ded3280ce27759c1f7b73259a6e2b5e584aa8'
- '58a94409205f7b670ab5745b8cbc234a38efd6a6217cef4efb7e397f091092e3e0c7790706b0a42accaa83d7509b8e244a98b9f0ba78349ee85f3164745c3501'
- 'f3bdbaac5dbe9384571fe5ec14d2d25035f227a977c25349b8188e7343804e3973b898b44c34f9abe9318666294f4fdfe780fd516dcbdb29c4ac52f6d0ed6cad'
+ '0b782de320b3e459380cd618d5db2f3998a6dae879a84a3e4c58b1c61ecb1109f7a63485c2d6c77682eb62ba4a4aa4763a1f25eadde52486f1ce481acbf02504'
+ '3fb051162e4dfc5aca3d4f41ebea18ac85d661f0ebba056a807a2a6ecf34ca117a11aeb286790f5ea6f9c6528d6b6981076da405ea0992ce8870bbe6951bdc2d'
+ '040363cea9b3492f8a0f8daba44c179c871ba691dea688c15f3ad6994f78d530b4f74b283b9c64e4f5a2b1268805e60d4ea154d3dc8246200c50907054f5b5ef'
'67cdb7e097bbb46da5cf04708bc2858b080d1a85742afc4c088da3e4e3fdeb6e4c51240fc5a6b9a1c7d927b30b3d251236e025ee4e5496142a7716d4ba51b82c'
- '71768899e631c5293d5fb8bcb237ca54f880913b6400d445c8a0322cb69801fe85b94b1293306e2f33fac6067cbd892c4665b9563bdc9ff4df5be245c7e7108f'
+ '822300e5eaf1964cd3e18efaf445b41f51212bec12db10e8963a86f185f0f460691efbb4e7dbeda57b2c5366784b99152c2df01b0d3686fb86bc44db289f7dab'
+ '025213998583972e7551bd7bd7376ab65857e28d4338fab60ae792a6b3bd48983aec77e5143baaa63d4f3feb7cd590c4bded529c410e4d18f2b8c5813f25daa3'
+ 'd9cad0cef682927c07e3f7398b6e57b21b68f9069b99fab363d0e3f329337f25fafa216a82a431ee23a2de3f67a0ed68d024c1a932b76f58aeb5e9a49cfe5e6e'
+ 'f3bdbaac5dbe9384571fe5ec14d2d25035f227a977c25349b8188e7343804e3973b898b44c34f9abe9318666294f4fdfe780fd516dcbdb29c4ac52f6d0ed6cad'
+ '43937dd83705b5ab62ae02cf1d043426c82f37e600afe06a287706e8450b596b84cc23138fbda31d67b9a2206ebfdc69754e329e7621075cbf480691f7d61871'
+ '76c816df10aceec8f1a7d1356220eb3f00b16fac455e84eb8aefe76db29cd037dc74fb5cfa344b8d283b188951bd100c26e351ce2e27c16c836a547fe2c99e46'
'417cd957f188b2b06e41d5413bea5f13481c6d5bfa8f184157379d5ac2afa9ba6f7ebc966856f50603f89b9173b6fbfdb3ccf4e3cc0b1bedb53f935591e4a35c'
- '80da2c341d8564a47bc460fcdaf9196ac3bb77f0f2ba56bd71089e80e7481728a3ccbdcfcbc3bf70a9c9e5d9d9b01f2ca6615b67c7ab61003808ce00f6545ba3'
- 'c1b6e59c840aee812570d9fb30f045b371473282c2289aaefe66483e6aae995fb93549882811fcb869d77f1c27a62ba4e486a8e20327846fd0602926739296ae'
- '74a51f04237fba3caa25b2e0d49659f2e8330ce82288de866943d06b53690f31d48a77a4dd2e57db1f435b715fbca792268f2e191ffb59e57170d327ed41ac0a'
- '8203bb062d72559da908a5020963503303c0aaa4a2ab61e57cfb713f58de40f1cb50b8b6dfbeec3a9addc41cbec5ae17fbf57230c3614f9b69fe6b0c55bf3fad'
'8bb71fbec3deece7bd0f9084e20ef5853812e71e2ebcd43011f7779499cbb99c7a8bc5c618d8ef9f55e5ce54c9fc4a5f4d3167bb63f9821a68889f9f3e1386f5'
'08f4746882b927bdff6b728630cf1e04a2b79924f694ca2d841e3115c3399feb87a8d363e4d2a0f59179c109cb6be6e840f912aadd44abb0bdb35afd2838cc4d'
+ 'ab35d6663b864449d46da4a9e1c51e11956ff4c38e16db58c831b71f7b964fc25b0283122dbc8aa0549f240f01c4a910fb5c6c82937258c6b736c05b54bcf768'
+ '8eef73575981d10a6a8734afc0e284ec7125db24bf666ff943938a4df87dedbd9ac622ea51bb71b5aaff7b1cc75627258bcfdc8659b915c09c82d3561fde1f62'
+ '71768899e631c5293d5fb8bcb237ca54f880913b6400d445c8a0322cb69801fe85b94b1293306e2f33fac6067cbd892c4665b9563bdc9ff4df5be245c7e7108f'
+ '8232c6a10fd1f608304982ae7f03eb8afc663be76cdc00aee46ecb58de838e21fdc8673841266ccd00153263f7b15b59dcd1fc6ece86834509d7ccb2cacf08fa'
+ 'ce0dd5121e814e0fcd79d68362c80a83bfe70f970be9d5d6f6fe5f6a56ed3f041be4d560aaf02225c3ce7c457dc63bc3adf0709d4b89a81c18184ff5341eb5d3'
+ 'b8a64accada87ee5be989c5307805610c9b5c0327bc107aab237ac3225dd9e4c51b6c79a2a7de15fe187d3c32d7cbe1c462f9b0e9fb5d5a55a74236c7061e96e'
+ '85aeb5920ee5879848be4057324153a077fe907bed527ed8f9b80a3c5ee1ef64786f63ee2999f5ba74e80a43e99ded3280ce27759c1f7b73259a6e2b5e584aa8'
+ '58a94409205f7b670ab5745b8cbc234a38efd6a6217cef4efb7e397f091092e3e0c7790706b0a42accaa83d7509b8e244a98b9f0ba78349ee85f3164745c3501'
+ '80da2c341d8564a47bc460fcdaf9196ac3bb77f0f2ba56bd71089e80e7481728a3ccbdcfcbc3bf70a9c9e5d9d9b01f2ca6615b67c7ab61003808ce00f6545ba3'
'651de880cefd51665d854414c451cc80a33ed8f34e7559a95514abd81a2f58348c37dd75f272468eefd56562ba8c99093a6dd9af3ea57796a9db15164a40eda3'
'7e41fc3a95073008ca2d71c2266d6d1a17af7803d493b447d40b15a86184c8ce3728b8d3d36765d408b1c46633d1bfa980d878cbac2e04b51ef518d44dfb7295'
- '76c816df10aceec8f1a7d1356220eb3f00b16fac455e84eb8aefe76db29cd037dc74fb5cfa344b8d283b188951bd100c26e351ce2e27c16c836a547fe2c99e46'
+ '2cdcf9ab03eb92f384caf1a2d90f82c75f880cb6286811e83217c883e421c116e7844ca193a010dc35e12eec46ede3663171a2f45f660ef5a8be95c474f61bfc'
'7cae5e42b6e16f3c4bf64dca3c7573c1b552424ff70bb6da0a21f121b53b2546b239c87953a090cd90f46a1c3c124e2fe19c560b1830b11334f8e64c92fb614d'
- 'ab35d6663b864449d46da4a9e1c51e11956ff4c38e16db58c831b71f7b964fc25b0283122dbc8aa0549f240f01c4a910fb5c6c82937258c6b736c05b54bcf768'
- 'e1d03f68918d03f980f4c2dd966e3788afe63f14e2d18dbd4dab2cdbfa1253e4823c0f5daa3a579e47319a3c2af35bc5af0a390e2ba91fe7621f6db8b1a60994'
- '846066151ff156ed18594748d965afa8d0f566c843ed3988055022408580bfb4e995b48048dc244be16d9f516b135937d8acda9e3334a63f3072df49208a0613'
- '8eef73575981d10a6a8734afc0e284ec7125db24bf666ff943938a4df87dedbd9ac622ea51bb71b5aaff7b1cc75627258bcfdc8659b915c09c82d3561fde1f62'
- '040363cea9b3492f8a0f8daba44c179c871ba691dea688c15f3ad6994f78d530b4f74b283b9c64e4f5a2b1268805e60d4ea154d3dc8246200c50907054f5b5ef'
- '43937dd83705b5ab62ae02cf1d043426c82f37e600afe06a287706e8450b596b84cc23138fbda31d67b9a2206ebfdc69754e329e7621075cbf480691f7d61871'
- 'd9cad0cef682927c07e3f7398b6e57b21b68f9069b99fab363d0e3f329337f25fafa216a82a431ee23a2de3f67a0ed68d024c1a932b76f58aeb5e9a49cfe5e6e'
'a45b2a53b6725dfd4780049a7522befe49c2a0c4efa4fb1dcb5cf53c7af18d329d2ba02aa6ac150342a3e66a46fd17f5e6e76a8db15c677a237edbb5cf4f5af7'
'653930e35eac5dc7bd9fa3bfe0cbe89a36284431dc53cab95697da6b45d4c63af854d884f6b63fd45fde9c53a334a7e4f5600378c57b3b2ae2f881ef5d8fd0e3'
+ '8203bb062d72559da908a5020963503303c0aaa4a2ab61e57cfb713f58de40f1cb50b8b6dfbeec3a9addc41cbec5ae17fbf57230c3614f9b69fe6b0c55bf3fad'
+ '74a51f04237fba3caa25b2e0d49659f2e8330ce82288de866943d06b53690f31d48a77a4dd2e57db1f435b715fbca792268f2e191ffb59e57170d327ed41ac0a'
+ 'e1d03f68918d03f980f4c2dd966e3788afe63f14e2d18dbd4dab2cdbfa1253e4823c0f5daa3a579e47319a3c2af35bc5af0a390e2ba91fe7621f6db8b1a60994'
'5a5a61ccb7e2e343fb6de2e3426688485a2f4ad65d4b001d8bd542907fd8ceb9315da7fd9e5f89a5aa6210edcd5f334c73657fc16349000d6f6a394303e22000'
- '5efa0a93e889efa022370a334b20aefb1103e8f9f700494207b7def18d55578be89955a117863b8342159eb1371a21aa55747fd83cc6aa5f424d0c024d157aef'
+ '617b1bacb05006385d2ff5198f297a0af7ce004148e62f7f90721f093fdf6445d0024039e1aa6bfd623276f80ed6922ce62c6b2e3b5f058230e26da2ef84273f'
+ '51b1324506179f7fadd8bc187eb8db939494483597b0b7b63909cec66f4e94b27888ccfa926bbd2ff8b0e80108ecc373118c202a177fc2ebd4f5231f87f09a83'
'92cde696eec00e6758b58e73e8bc60ad1a73bb2a18d4fdfd24a19b5be715305a047943a02d94a9703c101ca0c769dbeb816f1f28809345bae0fec42fbc27bb34'
'dede4f0774159243f87121e4d53107bb9de31f9658823fc7ab02124974b87defecf3ab0f2edf6779f2fe1ca437f16f83bf193cf3143fd5eb3a686b731319c11f'
'ce82294e480ad42f0001c799fd8131b60024b6097653f3c57564c75e54596616e376f0d7f1cf4e54d8c302a61ef164b4323f795bfa19b2c13ab9e927d37f1600'
@@ -128,6 +141,7 @@ b2sums=('28d01fe9a265419ad941d4ad2ca4cd1a5aafdc2e46dc1d734b718a60e3039e303f8c6b4
'f25f01c5b27dced202fe76c1717b9eaec65dfa5f28db1910529f60f5ec21cc89c1a15df26c2dd09066a0d89e3f7d87c790e7886c3c2f0978a25f5ec7d1236099'
'2aff3bb0804a1860bc95e25433b10f11c185bb954a2e9dc6fbee912d8d453498f9140d516ea4f31fc545861f266400db5d830092dbe21a48b22a07fd3d62a393'
'7835b2a650b7619af28e52273df6f279bac209528937abb32940f40b0572bc97c09573b139248213ab59e3a68ab7a5a96bb54adab742c2fc56d56f0e36732091'
+ '4bd44cbe85c53902b8a360509703e3d38e8a5da75dd2c534a77f03ce6440632f6c83c92939069c60473c88ffb3abab0fbf11e39271f44f813b9f6432ea5f9a6b'
'b01c79202a2ddc6e6e3e2b97f767f5535e29213bd675238fad20f5ac26b639a111424a3d2861fe2e760b73a1d3c1d909e0360390caf1f21a6fc169b0bee4d665'
'1a9518dadbc619cb97ca6dae4b6833083a312bd58d4596e4a231c005b3c89335a56bca62b644fc97340bdb37ff0f94043b5ba0b2d8ac379c8ef8b24adf2e7104'
'a56efdaae0344726debf5b74846edce8df7aa2357fbc7a05a3d369d1f457b02934a0d0ce2330072e03f1ac901e06e333c9393f795c761f8440307e7649ed5596'
@@ -149,120 +163,184 @@ prepare() {
sed -i 's|cataclysm-dda|cataclysm-bn|' src/path_info.cpp
# Fix version
- sed -i 's|VERSION = unstable|VERSION = 2021-10-16-1440|' Makefile
+ sed -i 's|VERSION = unstable|VERSION = 2021-10-29-1727|' Makefile
- # Hotfixes
+ # # # Hotfixes
+ #echo "Applying hotfixes"
- # Backports from 0.F
- # Fix tacoma barn doors being placed in the same spot twice.
- patch -Np1 -i "$srcdir"/0.F_backport-tacoma-barn-door-position.patch
+ # # # Various fixes for bugs I came across
+ # # Ammo fixes
+ echo "Applying ammo fixes"
+ # Fix mulitple inconsistent ammuntion names and handloaded status.
+ patch -Np1 -i "$srcdir"/ammo-01_inconsistent-ammo-names.patch
- # Fix npcs unable to drink from firestation and shelter basecamps wells.
- patch -Np1 -i "$srcdir"/0.F_backport-make-firestation-shelter-wells-npc-drinkable.patch
+ # Set a fixed loudness of 20x66mm shotgun shells like that of other shotguns:
+ # Other shotguns have fixed loudness to work around how the short range factors causes them to be far quieter than one would otherside expect.
+ patch -Np1 -i "$srcdir"/ammo-02_fix-20x66mm-loudness.patch
- # Fix radio, e-ink reader music, tactical tonfa not working with UPS.
- patch -Np1 -i "$srcdir"/0.F_backport-radio-can-use-ups.patch
+ # Change reloaded_50bmg to be based on 50bmg:
+ # The id and description make it pretty clear that reloaded_50bmg is not supposed to be based on Match rounds.
+ patch -Np1 -i "$srcdir"/ammo-03_fix-reloaded-50bmg.patch
+ # Replace several ammo fragmentation and explosive effects that are missing in BN with other ones.
+ patch -Np1 -i "$srcdir"/ammo-04_fix-missing-ammo-frag-effects.patch
- # Various other fixes for bugs I came across
- # Fix Quiverfull house to have the correct stairs that modify json.
- patch -Np1 -i "$srcdir"/0001-quiverfull-house-correct-stairs.patch
+ # Fix .22 casings not stacking when every other casing stacks.
+ patch -Np1 -i "$srcdir"/ammo-05_22-casings-can-stack.patch
- # Fix Ankle Ammo Pouch to not look like a backpack.
- patch -Np1 -i "$srcdir"/0002-ankle-ammo-pouch-is-not-a-backpack.patch
+ # Fix ammo ordering so as to not prevent those items being modded.
+ # Having copy-from items occuring earlier in a json than the item being copied from prevents items based on it being modified.
+ patch -Np1 -i "$srcdir"/ammo-10_ammo-order-fix.patch
- # Fix mulitple inconsistent ammuntion names and handloaded status.
- patch -Np1 -i "$srcdir"/0003-inconsistent-ammo-names.patch
- # Fix missing floor in tacoma clinic. The hospital is still a mess. :/
- patch -Np1 -i "$srcdir"/0004-tacoma-clinic-add-missing-floor.patch
+ # # armor fixes
+ echo "Applying armor fixes"
+ # Fix Ankle Ammo Pouch to not look like a backpack:
+ # SDG added a tile for ammo pouches to bypass this bug, but this fix still makes sense.
+ patch -Np1 -i "$srcdir"/armor-01_ankle-ammo-pouch-is-not-a-backpack.patch
- # Fix lumbermill gasoline being spilled instead of being inside the gas pump.
- patch -Np1 -i "$srcdir"/0005-lumbermill-gasoline-not-spilled.patch
+ # Fix fingerless survivor gloves losing base warmth:
+ # They lose warmth already from the lack of coverage, no need to double up.
+ patch -Np1 -i "$srcdir"/armor-02_fix-survivor-fingerless-gloves-warmth.patch
- # Fix community garden liquid fertilizer being in a pit instead of in the storage tanks.
- patch -Np1 -i "$srcdir"/0006-community-garden-fertilizer-not-spilled.patch
+ # # bionics fixes
+ echo "Applying bionic fixes"
# Fix npc not being able to install some additional CBMs:
# ie, soporific inducer, gasoline fuel cell, enhanced hearing, surgical scalpels.
- patch -Np1 -i "$srcdir"/0008-npc-can-use-more-bionics.patch
+ patch -Np1 -i "$srcdir"/bionics-01_npc-can-use-more-bionics.patch
- # Fix .22 casings not stacking when every other casing stacks.
- patch -Np1 -i "$srcdir"/0009-22-casings-can-stack.patch
- # Fix reloaded 45-70 rounds and reloaded dragon shot were not allowing dismantling when every other non-caseless does.
- patch -Np1 -i "$srcdir"/0010-4570-dragon-can-be-dismantled.patch
+ # # food fixes
+ echo "Applying food fixes"
+ # Fix several foods not being marked as the correct material:
+ # This prevents odd outcomes such as carnivores drinking almond/soy milk and eating peanut butter.
+ patch -Np1 -i "$srcdir"/foods-01_fix-food-materials.patch
- # Fix the pepperjack beef and burrito bowl MREs never dropping.
- patch -Np1 -i "$srcdir"/0011-add-missing-mre.patch
- # Fix some doors being unusable by npcs (incorrect door flag).
- patch -Np1 -i "$srcdir"/0012-fix-doors-for-npcs.patch
+ # # itemgroups fixes
+ echo "Applying itemgroup fixes"
+ # Stop police and SWAT carrying 4.6mm magazines despite having no compatible weapons:
+ # The H&K UCP was removed from the game some time ago.
+ patch -Np1 -i "$srcdir"/itemgroups-01_hk46-is-milspec.patch
- # Fix the loudness of 20x66mm shotgun shells like other shotguns.
- patch -Np1 -i "$srcdir"/0013-fix-20x66mm-loudness.patch
+ # Fix the pepperjack beef and burrito bowl MREs never dropping:
+ # They weren't in the itemgroups for MREs or soldier class.
+ patch -Np1 -i "$srcdir"/itemgroups-02_add-missing-mre.patch
- # Replace the portable generator twin engine with a large 1 cylinder so it can actually function as is.
- patch -Np1 -i "$srcdir"/0014-portable-generator-engine.patch
- # Normalize the manhack volumes to that of the base grenade/explosive.
- patch -Np1 -i "$srcdir"/0015-normalize-drone-volume.patch
+ # # monster fixes
+ echo "Applying monster fixes"
+ # Prefix medical zombies with "zombie" like other zombies:
+ # It just felt weird seeing "nurse" in the enemy list.
+ patch -Np1 -i "$srcdir"/monsters-01_medical-zombies-called-zombies.patch
- # Prefix medical zombies with "zombie" like other zombies.
- patch -Np1 -i "$srcdir"/0016-medical-zombies-called-zombies.patch
+ # # mutation fixes
+ echo "Applying mutation fixes"
# Light Step feels too powerful in Bright Nights.
- patch -Np1 -i "$srcdir"/0017-nerf-lightstep.patch
+ patch -Np1 -i "$srcdir"/mutations-01_nerf-lightstep.patch
+
+ # Fix Evacuee 3 background 3 being player visible:
+ # It was missing "player_display": false
+ patch -Np1 -i "$srcdir"/mutations-02_fix-evac3-background-visible.patch
+
+
+ # # recipe fixes
+ echo "Applying recipe fixes"
+ # Fix brioche bun missing a cooking time:
+ # It was missing a cooking time entirely resulting in instant cooking. Talk about quick rise bread.
+ patch -Np1 -i "$srcdir"/recipes-01_fix-brioche-cooking-time.patch
+
+ # Fix reloaded 45-70 rounds and reloaded dragon shot not allowing dismantling when every other non-caseless round does.
+ patch -Np1 -i "$srcdir"/recipes-02_4570-dragon-can-be-dismantled.patch
+
+
+ # # terrain and overmap fixes
+ echo "Applying terrain and overmap fixes"
+ # Fix Quiverfull house to have the correct stairwell direction:
+ # It was set to < for up, and not > for down.
+ patch -Np1 -i "$srcdir"/terrain-01_quiverfull-house-correct-stairs.patch
+
+ # Fix tacoma barn doors being placed in the same spot twice:
+ # This enables the southeast barn door to be placed properly.
+ patch -Np1 -i "$srcdir"/terrain-02_tacoma-barn-door-position.patch
+
+ # Fix missing floor in the tacoma clinic:
+ # The hospital is still a mess. :/
+ patch -Np1 -i "$srcdir"/terrain-03_tacoma-clinic-add-missing-floor.patch
+
+ # Fix lumbermill gasoline being spilled instead of being inside the gas pump:
+ # The gas pump was placed on top of a tile that didn't allow items inside, causing the gasoline to be shunted to the next valid one.
+ patch -Np1 -i "$srcdir"/terrain-04_lumbermill-gasoline-not-spilled.patch
+
+ # Fix community garden liquid fertilizer being in a pit instead of in the storage tanks:
+ # I'm pretty sure that having it all dumped in a pit was not intentional.
+ patch -Np1 -i "$srcdir"/terrain-05_community-garden-fertilizer-not-spilled.patch
+
+ # Fix some doors being unusable by npcs (incorrect door flag):
+ # The DOOR flag is for terrain that can be opened, not those already open.
+ patch -Np1 -i "$srcdir"/terrain-06_fix-doors-for-npcs.patch
# Re-hide something that feels like spoilers.
- patch -Np1 -i "$srcdir"/0018-rehide-redacted.patch
+ patch -Np1 -i "$srcdir"/terrain-07_rehide-redacted.patch
# Set the overmap note for Derelict Shed to s to better match use of the first letter.
- patch -Np1 -i "$srcdir"/0019-derelict-shed-is-s.patch
+ patch -Np1 -i "$srcdir"/terrain-08_derelict-shed-is-s.patch
- # Stop police and SWAT carrying 4.6mm magazines despite having no compatible weapons.
- patch -Np1 -i "$srcdir"/0020-hk46-is-milspec.patch
+ # Fix npcs unable to drink from firestation and shelter basecamps wells:
+ # They were missing the water_well blueprint_provides.
+ patch -Np1 -i "$srcdir"/terrain-09_make-firestation-shelter-wells-npc-drinkable.patch
- # Mark the foldable plastic bottle and steel water bottle as containers.
- patch -Np1 -i "$srcdir"/0021-foldable-bottle-is-container.patch
- # Fix Evacuee 3 background 3 being player visible.
- patch -Np1 -i "$srcdir"/0022-fix-evac3-background-visible.patch
+ # # tool fixes
+ echo "Applying tool fixes"
+ # Mark the foldable plastic bottle and steel water bottle as containers:
+ # Being counted as tools didn't seem to fit their role.
+ patch -Np1 -i "$srcdir"/tools-01_foldable-bottle-is-container.patch
- # Fix rubber items dismantling into 10x item volume of rubber.
- patch -Np1 -i "$srcdir"/0023-fix-rubbersplosion.patch
+ # Fix blood draw kit being categorized as a weapon:
+ # Upstream changed item templates, so this sets it back to be a tool.
+ patch -Np1 -i "$srcdir"/tools-02_vacutainer-is-not-a-weapon.patch
- # Fix ammo ordering so as to not prevent those items being modded.
- patch -Np1 -i "$srcdir"/0024-ammo-order-fix.patch
+ # Fix electric shears not using batteries nor charging via UPS:
+ # Item was unusable without this patch.
+ patch -Np1 -i "$srcdir"/tools-03_shears-use-light-battery.patch
- # Fix brioche bun missing a cooking time.
- patch -Np1 -i "$srcdir"/0026-fix-brioche-cooking-time.patch
+ # Normalize the manhack volumes to that of the base grenade/explosive:
+ # I don't see how a c-4 manhack could be 1/4 the volume of a stick of c-4.
+ # Grenade hacks were also thrice as big as the base grenade.
+ patch -Np1 -i "$srcdir"/tools-04_normalize-drone-volume.patch
- # Fix ammo fragmentation and explosive effects that are missing.
- patch -Np1 -i "$srcdir"/0027-fix-missing-ammo-frag-effects.patch
- # Fix several foods not being marked as the correct material.
- patch -Np1 -i "$srcdir"/0028-fix-food-materials.patch
+ # # vehicle fixes
+ echo "Applying vehicle fixes"
+ # Replace the portable generator twin engine with a large 1 cylinder:
+ # This way it can actually function as is.
+ patch -Np1 -i "$srcdir"/vehicles-01_portable-generator-engine.patch
- # Fix fingerless survivor gloves losing base warmth, as they lose warmth already from the lack of coverage.
- patch -Np1 -i "$srcdir"/0029-fix-survivor-fingerless-gloves-warmth.patch
- # Fix blood draw kit being categorized as a weapon.
- patch -Np1 -i "$srcdir"/0031-vacutainer-is-not-a-weapon.patch
- # Fix electric shears not using batteries nor charging via UPS.
- patch -Np1 -i "$srcdir"/0032-shears-use-light-battery.patch
+ # # Uncategorized for now
+ echo "Applying uncategorized fixes"
+ # Fix rubber items dismantling into 10x item volume of rubber.
+ patch -Np1 -i "$srcdir"/etc-01_fix-rubbersplosion.patch
# Add price_postapoc to a number of items that did not have one set.
- patch -Np1 -i "$srcdir"/0033-add-missing-price-postapoc.patch
+ patch -Np1 -i "$srcdir"/etc-02_add-missing-price-postapoc.patch
+
+ # Revert the book changes for now.
+ patch -Np1 -i "$srcdir"/etc-03_revert-book-revamp.patch
+ rm data/json/items/book/bloat.json
- # The id and description make it pretty clear that reloaded_50bmg is not supposed to be based on Match rounds.
- patch -Np1 -i "$srcdir"/0034-fix-reloaded-50bmg.patch
+ # # # Various other fixes for bugs I came across that modify src
+ echo "Applying source code fixes"
+ # Fix radio, e-ink reader music, tactical tonfa not working with UPS.
+ patch -Np1 -i "$srcdir"/jc_radio-can-use-ups.patch
- # Various other fixes for bugs I came across that modify src
# Fix ammo loudness mulitplying by six instead of two.
patch -Np1 -i "$srcdir"/jc_ammo-loudness-ap-times-2.patch
@@ -287,7 +365,13 @@ prepare() {
# Expand the overmap tiles for the miltiary base to be less MMMM
patch -Np1 -i "$srcdir"/jc_more-military-base-overmap.patch
- # A series of changes to add both gynoid and vampire mutation lines.
+ # Allow npcs to pull food from the camp larger at the full range of tiles camp actions can be assigned from.
+ patch -Np1 -i "$srcdir"/jc_npc-eat-from-further-camp.patch
+
+
+ # # # Additional changes
+ echo "Applying gynoid and vampire patch"
+ # Add gynoid and vampire mutation lines. might require vampire stuff redone mod.
patch -Np1 -i "$srcdir"/custom.patch
}