summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2024-02-04 00:30:36 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2024-02-04 00:30:36 -0800
commitc3829543091f66f9a47a02714ae11d7c579950ce (patch)
treec3896fd6e4efbc0fef5f7d68b6792622d59a3b06 /PKGBUILD
parentUpdate vampirism mod with partial_deaf for the vamp_hearing trait. (diff)
downloadcataclysm-bn-c3829543091f66f9a47a02714ae11d7c579950ce.tar.xz
Apply hotfixes.
-monsters won't attack idle mechsuits -reloading no longer deletes empty containers -look around won't overlap text -no more safe reference error on save and quit -zombies no longer smell through glass
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 29 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3defce2..098d590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _pkgname=Cataclysm-BN
pkgver=0.5.2
#pkgver=202310040030
#_pkgver=2023-10-04-0030
-pkgrel=4
+pkgrel=5
pkgdesc="A post-apocalyptic roguelike."
#url="http://cataclysmrl.blogspot.com/"
#url="http://www.cataclysm.glyphgryph.com/"
@@ -59,6 +59,12 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/cataclysmbnteam/Cataclysm-B
"revert-27_fix-NPCs-keep-their-splints-on-3589.patch"
"revert-28_feat-content-semi-plausible-smokeless-gunpowder-reci.patch"
+ "hotfix-01_fix-monsters-ignore-mechs-that-aren-t-being-piloted-.patch"
+ "hotfix-02_fix-Prevents-reloading-from-deleting-containers-4104.patch"
+ "hotfix-03_fix-Fix-overlapping-text-in-look-around.-4156.patch"
+ "hotfix-04_fix-uaf-in-safe-references-4165.patch"
+ "hotfix-05_feat-balance-closed-glass-windows-block-scent-4114.patch"
+
"ammo-10_ammo-order-fix.patch"
"ammo-11_fix-volume-40mm.patch"
"ammo-12_fix-20x66mm-loudness.patch"
@@ -178,6 +184,11 @@ b2sums=('9daaba287ef99aa3b33b6f3fbb129b97a2b4dcc265dd7affa08ccee1bdd41b4568e061a
'6735377f8611451333c8d7f009001aa652af9edeeddfcd0cd163d03ea84607803d260eb1338fa35f688954c3cb75bb7bdc41a5ad0497771815dd16afa86d54b3'
'13e61e9144f4d7325c409553c72ea1fca07009939b53491ea24d208fba7539e7f09063911c76e7d45f7e6bda12a61bbde17a75c319a0b79518e6639d520fa4ef'
'c4ee693418d394e3b946aa2b9a5f11c04bb0ff11234f830056963f4a755357552f9a769688a086f56f492ed479cf1a44032cfde45c03627adc5fb55f88f806e6'
+ '32714f9869cbf44847c5cd2d4b4d6e69a47450a3dd2bd92a195686d938162a86717c4e1c28dab48d8b62fbe0271e0eead5ea9c727aa547787643172fe3b48751'
+ '54ed3733d646b549b4db8eded9aeb08de1df328c63c4a535971cf03de172349421b4e96d495995ea5abd2cf63b2df46c2fee9d526eea414bd9463e920802fe78'
+ '29bc7e4f9ca7437930a43455be8d1166ff2b7bbaaa58209692d4a15fa7c4b19a4b185881d9a1c5abafe363de31f31fe44585da24dbeecaba183e884539443228'
+ 'af8d397d3b42ec0ff461337c19e470dd05b367a362cff092dbe6083841fee062cf899799e69db11fba05179775ac398f8ef3bf79a9f0e25b8774350451e73363'
+ 'b388513e6e2d67b3c6ae4f7c27d59bcd78fac9909e887fa4c58932052c0f3355b1dad23abfe404ca2bec82e278759e5be5982abb8b5b1dc7c908c51f7a510d05'
'df26a597afe46a35e07f02c32839e2f7f57cf4d4d9bf0e62eb645d1b720f601fe2e9787462a0ab0ba8b788c727b846272a4ca6ecf81f96bb058d070b53633dcc'
'ba2964e64df20167c722e71951db28d039e637397a6be2e7f5312da10ab3c57a1982ec1ae1c37dd361317292b8c519f678472eb06360d4368294e0b636704c15'
'365e1ac9f9ee636f2578f6fd8ab16b6460894cb9b76cf0aee5d8a55f42d882d6ee0b04e80194f4c346bfdb0778e11e30b8c03541b4d351602ccfd63cee7e3cf0'
@@ -291,6 +302,23 @@ prepare() {
# # # Hotfixes
echo "Applying hotfixes"
+
+ # Fix monsters attacking idle mechsuits
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-01_fix-monsters-ignore-mechs-that-aren-t-being-piloted-.patch
+
+ # Fix containers being deleted when reloading empties a container
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-02_fix-Prevents-reloading-from-deleting-containers-4104.patch
+
+ # Fix overlapping text when looking around
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-03_fix-Fix-overlapping-text-in-look-around.-4156.patch
+
+ # Fix safe reference error on save and quit
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-04_fix-uaf-in-safe-references-4165.patch
+
+ # Fix zombies having a psychic sense of smell
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-05_feat-balance-closed-glass-windows-block-scent-4114.patch
+
+
# # Adjust default mods
patch -Np1 --no-backup-if-mismatch -i "$srcdir"/src-20_fix-default-mods.patch