summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ec2251..8defaf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
# # I maintain this because:
# Arch version lacks additional optimization and hardening flags
+# Arch version has non-functional desktop file
pkgbase=cataclysm-dda
pkgname=(cataclysm-dda cataclysm-dda-tiles)
pkgname=cataclysm-dda
pkgver=0.D
-pkgrel=1
+pkgrel=1.2
pkgdesc="A post-apocalyptic roguelike."
#url="http://cataclysmrl.blogspot.com/"
#url="http://www.cataclysm.glyphgryph.com/"
@@ -18,8 +19,12 @@ arch=('x86_64')
license=("CCPL:by-sa")
depends=('ncurses' 'lua' 'hicolor-icon-theme' 'gettext')
makedepends=('sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'freetype2' 'astyle')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/CleverRaven/Cataclysm-DDA/archive/$pkgver.tar.gz")
-sha256sums=('6cc97b3e1e466b8585e8433a6d6010931e9a073f6ec060113161b38052d82882')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/CleverRaven/Cataclysm-DDA/archive/$pkgver.tar.gz"
+ "cataclysm-dda.desktop"
+ "O3-support.patch")
+sha256sums=('6cc97b3e1e466b8585e8433a6d6010931e9a073f6ec060113161b38052d82882'
+ 'f101e659e61bf3c20d282852c3e35aaa7890be44f9ae0d805575b213c41e429f'
+ '0720e142574b87b26b532448fca241aa3b3a39d75bd758e77b991066b8a4109b')
# official docs say to use lua51
# but makefile supports lua52?
@@ -31,6 +36,7 @@ prepare() {
sed -i 's/ncursesw5-config/ncursesw6-config/' Makefile
#sed -i 's|"\(l.*h\)"|"lua5.1/\1"|' src/catalua.{h,cpp}
sed -i 's/shell git/shell false/' Makefile
+ patch -p1 -i "${srcdir}/O3-support.patch"
}
build() {
@@ -61,6 +67,8 @@ package_cataclysm-dda() {
# License
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
package_cataclysm-dda-tiles() {
@@ -72,6 +80,7 @@ package_cataclysm-dda-tiles() {
# Icon
install -D 'data/osx/AppIcon.iconset/icon_128x128.png' "$pkgdir/usr/share/icons/hicolor/128x128/apps/cataclysm-dda.png"
+ install -D 'data/osx/AppIcon.iconset/icon_128x128.png' "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"