summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..3e6a37c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor (Arch): Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor (Arch): Daniel Micay <danielmicay@gmail.com>
+# Contributor (Arch): Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor (Arch): Patrick Leslie Polzer <leslie.polzer@gmx.net>
+# Contributor (Arch): cdhotfire <cdhotfire@gmail.com>
+# Contributor (Arch): Shinlun Hsieh <yngwiexx@yahoo.com.tw>
+# Contributor (Arch): Elisamuel Resto <ryuji@simplysam.us>
+
+# # I maintain this because:
+# Arch version is not configured for openrc
+# Arch version uses /etc/chrony.conf instead of /etc/chrony/chrony.conf
+
+pkgname=chrony
+pkgver=3.4
+pkgrel=2
+pkgdesc='Lightweight NTP client and server'
+url='https://chrony.tuxfamily.org/'
+arch=('x86_64')
+license=('GPL2')
+depends=('glibc' 'nss' 'readline' 'libcap' 'libedit' 'libseccomp' 'nettle')
+makedepends=('asciidoctor')
+options=('!emptydirs')
+backup=('etc/chrony/chrony.conf')
+source=(https://download.tuxfamily.org/chrony/${pkgname}-${pkgver}.tar.gz
+ ${pkgname}-${pkgver}.tar.gz.asc::https://download.tuxfamily.org/chrony/${pkgname}-${pkgver}-tar-gz-asc.txt
+ chrony.sysusers
+ chrony.tmpfiles)
+sha256sums=('af77e47c2610a7e55c8af5b89a8aeff52d9a867dd5983d848b52d374bc0e6b9f'
+ 'SKIP'
+ '56aa817638c8f959169d514f1e7fc727ef31e7d3beda4fca5165292c7602ee42'
+ 'c0b52787f68f3ef365eef64f53f22b4fb0046a91f0e38923f9d16f1ca19c3f3a')
+validpgpkeys=('8B1F4A9ADA73D401E3085A0B5FF06F29BA1E013B') # Miroslav Lichvar <mlichvar@redhat.com> has a dsa1024 key *in the wild*
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ sed -i \
+ -e 's|pool.ntp.org|3.arch.pool.ntp.org|g' \
+ -e 's|server foo.example.net|server 0.arch.pool.ntp.org iburst|g' \
+ -e 's|server bar.example.net|server 1.arch.pool.ntp.org iburst|g' \
+ -e 's|server baz.example.net|server 2.arch.pool.ntp.org iburst|g' \
+ examples/chrony.conf.example*
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --enable-scfilter \
+ --enable-ntp-signd \
+ --with-user=chrony \
+ --with-sendmail=/usr/bin/sendmail \
+ --with-hwclockfile=/etc/adjtime
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install install-docs
+
+ install -Dm 644 "${srcdir}/chrony.sysusers" "${pkgdir}/usr/lib/sysusers.d/chrony.conf"
+ install -Dm 644 "${srcdir}/chrony.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/chrony.conf"
+ install -Dm 644 examples/chrony.logrotate "${pkgdir}/etc/logrotate.d/chrony"
+ install -Dm 644 README NEWS FAQ -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 examples/* -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
+
+ mkdir -p ${pkgdir}/etc/chrony
+ install -Dm 644 examples/chrony.conf.example3 "${pkgdir}/etc/chrony/chrony.conf"
+ echo -e "\n# Enable kernel RTC sync\nrtcsync" >> "${pkgdir}/etc/chrony/chrony.conf"
+ sed -i '/^! rtconutc$/ s/^! //' "${pkgdir}/etc/chrony/chrony.conf"
+
+ mv "${pkgdir}/usr/sbin/chronyd" "${pkgdir}/usr/bin"
+ rmdir "${pkgdir}"{/usr/sbin,/var/lib/chrony,/var/lib}
+}