summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2022-07-07 21:00:39 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2022-07-07 21:00:39 -0700
commit4659b02952495fe48badd61d069300f0dab30dcc (patch)
tree97a0e821296c5eb69eebce98c06c54eee0db6045 /PKGBUILD
parentMore optimizations. (diff)
downloaddesmume-4659b02952495fe48badd61d069300f0dab30dcc.tar.xz
Updated to 0.9.13
-Yes, this is the first new release in seven years.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 27 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8794e37..f9223e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,48 +12,48 @@
# Contributor (Arch): Asher256 <achrafcherti at gmail dot com>
# # I maintain this because:
+# Arch version is out of date
# Arch version lacks additional optimization and hardening flags
pkgname=desmume
-pkgver=0.9.11
-pkgrel=8.2
+pkgver=0.9.13
+_pkgver=0_9_13
+pkgrel=1
pkgdesc="Nintendo DS emulator"
arch=('x86_64')
url="https://desmume.org/"
license=('GPL')
-depends=('desktop-file-utils' 'libpcap' 'soundtouch' 'alsa-lib' 'glu' 'sdl' 'gtk2' 'zziplib')
-makedepends=('intltool' 'mesa' 'clang')
-source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
- gcc6_fixes.patch
- gcc7_fixes.patch)
-sha256sums=('3ab34ba6cc009566245025c1dd94bf449b6a1b416d24387cb42e183c78e38896'
- 'dfb25d204253ca1dad2218e54760c81872c1df0b70c12067591a6578159b9aef'
- 'b8f419f5286c1ee08f824250cabc7f4984a572f55db8182070b0bf3235134d1f')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # Fix build
- patch -Np1 -i ../gcc6_fixes.patch
- patch -Np1 -i ../gcc7_fixes.patch
-
-
- # See https://bugs.archlinux.org/task/35086 and
- # https://sourceforge.net/tracker/?func=detail&aid=3612768&group_id=164579&atid=832291
- sed -i 's/@GETTEXT_PACKAGE@/desmume/' po/Makefile.in.in
-}
+# # For some reason this breaks compiling. "error: C++ compiler cannot create executables"
+# # But old-fashioned raw injection of -flto=auto via export doesn't.
+#options=(lto)
+depends=('desktop-file-utils' 'libpcap' 'soundtouch' 'alsa-lib' 'glu' 'sdl2' 'gtk2' 'zziplib')
+makedepends=('intltool' 'mesa')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/TASEmulators/${pkgname}/archive/refs/tags/release_${_pkgver}.tar.gz")
+sha256sums=('7e513f3112ac2955bd0951bc00a94f10220999b036745bde5ac01eb524e05b57')
+b2sums=('d63ed03801a15a3429c12b05da4ff2e4ea851a7dc307d4a4e02b6a0f74b2c4fab3a27ff14f6c563c9b84a827bb7d7db3083884154049cf8a8ffd5df6aa310e5c')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=auto -fPIE -fuse-linker-plugin -minline-all-stringops"
- export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=auto -fPIE -fuse-linker-plugin -minline-all-stringops"
+ cd "$srcdir/${pkgname}-release_${_pkgver}/${pkgname}/src/frontend/posix/"
+
+ # Prevents build failure
+ CXXFLAGS+=" -Wno-error=format-security"
+
+ # Upstream suggested
+ export CFLAGS="$CFLAGS -fuse-linker-plugin -minline-all-stringops"
+ export CXXFLAGS="$CXXFLAGS -fuse-linker-plugin -minline-all-stringops"
+
+ # General optimizations
+ export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=auto -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=auto -fPIE"
export LDFLAGS="$LDFLAGS,-pie"
+
+ autoreconf -i
./configure --prefix=/usr --enable-wifi --enable-openal
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/${pkgname}-release_${_pkgver}/${pkgname}/src/frontend/posix/"
make DESTDIR="$pkgdir/" install
}