summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2021-06-18 16:30:12 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2021-06-18 16:30:12 -0700
commitd9442b8a5c84de4d6b52715c17979f63bc673b1b (patch)
treec2018f64d5eafa738ec85c313988969b48df23e1 /PKGBUILD
parentUpdated to 0.9.13 (diff)
downloadendless-sky-d9442b8a5c84de4d6b52715c17979f63bc673b1b.tar.xz
Sync with changes made from the switch to community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 31 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 315b99d..4a3285e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,37 @@
# # I maintain this because:
-# AUR version uses /usr/share/games
+# Arch version lacks additional optimization and hardening flags
pkgname=endless-sky
pkgver=0.9.13
-pkgrel=1
+pkgrel=2
+pkgdesc="A sandbox-style space exploration and combat game"
arch=('x86_64' 'i686' 'aarch64')
url="https://endless-sky.github.io/"
-depends=(gcc-libs openal libpng glew hicolor-icon-theme libjpeg-turbo sdl2 libmad)
-makedepends=(scons)
-optdepends=('endless-sky-high-dpi: high resolution graphics assets'
- 'endless-sky-editor: map editor')
-license=('GPL3' 'CCPL' 'custom:public domain')
-pkgdesc="A sandbox-style space exploration and combat game"
+license=(
+ 'GPL3'
+ 'custom:CC-BY-3.0'
+ 'custom:CC-BY-4.0'
+ 'custom:CC-BY-NC-3.0'
+ 'custom:CC-BY-SA-3.0'
+ 'custom:CC-BY-SA-4.0'
+ 'custom:public-domain'
+)
+depends=(
+ 'gcc-libs'
+ 'openal'
+ 'libpng'
+ 'glew'
+ 'hicolor-icon-theme'
+ 'libjpeg-turbo'
+ 'sdl2'
+ 'libmad'
+)
+makedepends=('scons')
+optdepends=(
+ 'endless-sky-high-dpi: high resolution graphics assets'
+)
source=("$pkgname-$pkgver.tar.gz::https://github.com/endless-sky/endless-sky/archive/v${pkgver}.tar.gz")
b2sums=('6d4c7f37ce4dfff2bae3eb6cee4948e6e27df086c2017f56bddf2d212011bfff135931915ab3f34c5e2f432acbf38126f7a774835d427652c8870d98e66c5f06')
@@ -36,33 +54,13 @@ build() {
scons "${MAKEFLAGS}"
}
-
package() {
cd "$pkgname-$pkgver"
- scons DESTDIR="$pkgdir" PREFIX=/usr install
-
- # binary
- #install -Dm755 endless-sky "${pkgdir}/usr/bin/endless-sky"
-
- # resources
- # hard coded paths are evil
- #install -Dm644 credits.txt "${pkgdir}/usr/lib/${pkgname}/credits.txt"
- #install -Dm644 keys.txt "${pkgdir}/usr/lib/${pkgname}/keys.txt"
- #cp -rf data images sounds "${pkgdir}/usr/lib/${pkgname}/"
-
- # .desktop
- #install -Dm644 ${srcdir}/endless-sky.desktop "${pkgdir}/usr/share/applications/endless-sky.desktop"
-
- # icons
- #for res in 16 22 24 32 48 128 256 512; do
- # install -Dm644 \
- # "icons/icon_${res}x${res}.png" \
- # "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${pkgname}.png"
- #done
-
- # manpage
- #install -Dm644 -t "${pkgdir}/usr/share/man/man6" endless-sky.6
+ scons \
+ DESTDIR="$pkgdir" \
+ PREFIX=/usr \
+ install
# license
- install -Dm644 copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" copyright
}