summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b1f18a..4a1b5ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ makedepends=(scons)
optdepends=('endless-sky-high-dpi: high resolution graphics assets'
'endless-sky-editor: map editor')
license=('GPL3' 'CCPL' 'custom:public domain')
-pkgdesc="A space exploration and combat game similar to Escape Velocity"
+pkgdesc="A sandbox-style space exploration and combat game"
source=("$pkgname-$pkgver.tar.gz::https://github.com/endless-sky/endless-sky/archive/v${pkgver}.tar.gz"
${pkgname}.desktop
0001-fix-Add-missing-string-include.patch)
@@ -33,8 +33,8 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- export CFLAGS="$CFLAGS -O3 -flto=4 -fPIE"
- export CXXFLAGS="$CXXFLAGS -O3 -flto=4 -fPIE"
+ export CFLAGS="$CFLAGS -O3 -flto=auto -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -flto=auto -fPIE"
export LDFLAGS="$LDFLAGS,-pie"
scons "${MAKEFLAGS}"
}
@@ -43,7 +43,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- # Install executable
+ # binary
install -Dm755 endless-sky "${pkgdir}/usr/bin/endless-sky"
# resources
@@ -58,7 +58,7 @@ package() {
# icons
for res in 16 22 24 32 48 128 256 512; do
install -Dm644 \
- "${srcdir}/${pkgname}-${pkgver}/icons/icon_${res}x${res}.png" \
+ "icons/icon_${res}x${res}.png" \
"${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${pkgname}.png"
done