summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbade93..0b1f18a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=endless-sky
pkgver=0.9.12
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64' 'aarch64')
url="https://endless-sky.github.io/"
depends=(openal libpng glew hicolor-icon-theme libjpeg-turbo sdl2 libmad)
@@ -22,7 +22,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/endless-sky/endless-sky/arc
${pkgname}.desktop
0001-fix-Add-missing-string-include.patch)
b2sums=('8df20650524cb179e92306084668a8e341f88ca5adb1c6b6e2e48d450556a36556efcbff256dd6c0f47b4435739cfdbc7af357285af4ab15d5355e8f0ecba923'
- '8cb5f3300c003ae2c2316ac0ad342c7baa90851013e94811ec076cb6274d998b2aa9e0139b5bcb757b645c15382b4d2cb3f267eae589006902468e04a0534d01'
+ 'cccce9f6d4da294ab7f71a6f441c6c04fb9498dd0e6a90f4566fcbbfdb70fd90b8ec966e82678739340d35a3f906e34c9d5ea0e3b590897a79bbab0e8763ef9b'
'87bce26dee8a4626ebdd2a8cc71ec87ca48c55295853db7b824a3429a96552a0fa00c2b8dcd009ece889937e5bfeba5ce983f1a399fb1437dfa0d5af213adb08')
# remove this in the next version, as the patch is backported from upstream
@@ -47,9 +47,10 @@ package() {
install -Dm755 endless-sky "${pkgdir}/usr/bin/endless-sky"
# resources
- install -Dm644 credits.txt "${pkgdir}/usr/share/${pkgname}/credits.txt"
- install -Dm644 keys.txt "${pkgdir}/usr/share/${pkgname}/keys.txt"
- cp -rf data images sounds "${pkgdir}/usr/share/${pkgname}/"
+ # hard coded paths are evil
+ install -Dm644 credits.txt "${pkgdir}/usr/lib/${pkgname}/credits.txt"
+ install -Dm644 keys.txt "${pkgdir}/usr/lib/${pkgname}/keys.txt"
+ cp -rf data images sounds "${pkgdir}/usr/lib/${pkgname}/"
# .desktop
install -Dm644 ${srcdir}/endless-sky.desktop "${pkgdir}/usr/share/applications/endless-sky.desktop"