summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-05-06 10:46:42 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-05-06 10:46:42 -0700
commit0c31a69c917620da91fe77bdf02eb5adc821ba3e (patch)
tree8c9777e15cf94aeecbc7e6e1d339636fe878c900 /PKGBUILD
parentUpdated to 66.0.4 (diff)
downloadfirefox-esr-0c31a69c917620da91fe77bdf02eb5adc821ba3e.tar.xz
Unify build with firefox-basic
Offload vendor.js to a new package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 128302f..e5b4e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
pkgname=firefox
pkgver=66.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -25,17 +25,21 @@ url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss ttf-font alsa-lib sqlite libvpx icu)
makedepends=(unzip zip diffutils python-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust clang llvm gtk2
- python python2 nodejs python-psutil cbindgen nasm)
+ xorg-server-xvfb autoconf2.13 rust clang llvm gtk2
+ python python2 nodejs python-psutil cbindgen nasm
+ jack libpulse
+ )
optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'jack: Jack audio support'
'libnotify: Notification integration'
+ 'libpulse: PulseAudio support'
'speech-dispatcher: Text-to-Speech'
- 'hunspell-en_CA: Spell checking, Canadian English')
+ 'hunspell-en_CA: Spell checking, Canadian English'
+ 'firefox-config: Custom vendor.js')
options=(!emptydirs !makeflags)
source=("https://archive.mozilla.org/pub/$pkgname/releases/$pkgver/source/$pkgname-$pkgver.source.tar.xz"{,.asc}
$pkgname.desktop $pkgname-symbolic.svg
0001-bz-1468911.patch
- vendor.js
pgo-1.patch
moz.configure.diff
package-manifest.diff)
@@ -44,7 +48,6 @@ sha256sums=('7ac6fae17e402276483fbfbb6b320d61e6695a28f1112ba2c987127f105dc25d'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
'821f858bac2e13ce02b8c20d5387d4ecc8ab2d0e4ebe0a517cbf935da6aeb31b'
- '18dfd0695d3ae03bc53425daa6576b6951f96abbca267949b41c459a9e84c28d'
'a8c15c9d54ef8b360c0932f4ccf5e74954f14e9a9c2a1ae924b6c392075b2b8c'
'ad8a270e1b2affb098440f82517c3952207b28ebf604fef695dad3e29a5ba30e'
'927e400d6920b98d2fe7db2b6498f195135909a76e0da49441223956364d8227')
@@ -95,7 +98,7 @@ ac_add_options --with-system-zlib
# Features
ac_add_options --enable-alsa
-ac_add_options --disable-pulseaudio
+ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-debug
@@ -157,8 +160,6 @@ package() {
cd ${pkgname}-${pkgver}
DESTDIR="$pkgdir" ./mach install
- install -Dm644 "$srcdir/vendor.js" "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
-
_distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
install -Dm644 /dev/stdin "$_distini" <<END