summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-03-14 10:58:20 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-03-14 10:58:20 -0700
commit1b5866fe96e9a2f9636e8c4b8cd0ac4b2be4b085 (patch)
tree4ac23b781f3001ca83626242a279ad4dbc591496 /PKGBUILD
parentlibvpx rebuild (diff)
downloadfirefox-esr-1b5866fe96e9a2f9636e8c4b8cd0ac4b2be4b085.tar.xz
Updated to 59.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f62d66a..4310905 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox
-pkgver=58.0.1
-pkgrel=3
+pkgver=59.0
+pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
-depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
nss hunspell sqlite ttf-font libpulse libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack)
+ autoconf2.13 rust mercurial clang llvm jack gtk2)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -21,24 +21,20 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip !debug)
_repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
- $pkgname.desktop
- firefox-symbolic.svg
- firefox-install-dir.patch
+ $pkgname.desktop firefox-symbolic.svg
no-crmf.diff
vendor.js)
sha256sums=('SKIP'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- 'a94f80abe65608cd49054a30acc31e4d0885fe5b2a38cf08ded5e5b51b87c99d'
- 'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
- 'e36cc420ad02d8825e7e835e9853130b12b72218de10da9f07d8599a95700093')
+ '02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
+ 'f5fa8873f8e3890780b857baa3569151921dbf266b9c2af27a43958169303e2c')
prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
cd mozilla-unified
- patch -Np1 -i ../firefox-install-dir.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff
@@ -57,6 +53,7 @@ ac_add_options --enable-rust-simd
ac_add_options --disable-official-branding
ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=
+export MOZILLA_OFFICIAL=0
export MOZ_TELEMETRY_REPORTING=0
export MOZ_ADDON_SIGNING=0
export MOZ_REQUIRE_SIGNING=0
@@ -124,14 +121,10 @@ app.distributor.channel=$pkgname
app.partner.archlinux=archlinux
END
- for i in 16 22 24 32 48 256; do
+ for i in 16 22 24 32 48 64 128 256; do
install -Dm644 browser/branding/official/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done
- install -Dm644 browser/branding/official/content/icon64.png \
- "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
- install -Dm644 browser/branding/official/mozicon128.png \
- "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
install -Dm644 browser/branding/official/content/about-logo.png \
"$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
install -Dm644 browser/branding/official/content/about-logo@2x.png \