summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-06-14 23:25:12 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-06-14 23:25:12 -0700
commit59b7217f517471f0ce16267ec5104a04ab5c53f0 (patch)
treeedda0f109f397c69331c5aec20b159c6ab93d957 /PKGBUILD
parentUpdated to 60.0.1 (diff)
downloadfirefox-esr-59b7217f517471f0ce16267ec5104a04ab5c53f0.tar.xz
Updated to 60.0.2 | Switched to alsa | Updated vendor.js
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 257e787..45d9307 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,18 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox
-pkgver=60.0.1
+pkgver=60.0.2
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font libpulse libvpx icu)
+ nss hunspell sqlite ttf-font alsa-lib libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack gtk2)
+ autoconf2.13 rust mercurial clang llvm gtk2)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
- 'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip)
_repo=https://hg.mozilla.org/mozilla-unified
@@ -32,7 +31,7 @@ sha256sums=('SKIP'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
'02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
- 'ea7c74586629bf0a888e0a67c2d3ce155a45a34f5391e49e478d5bdcd09fed8b')
+ 'db998007bbc6b00cf5079efa6b2b72302600517cf415d999aa656415709fbbff')
prepare() {
mkdir path
@@ -80,7 +79,7 @@ ac_add_options --enable-system-ffi
# Features
ac_add_options --enable-alsa
-ac_add_options --enable-jack
+ac_add_options --disable-pulseaudio
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-eme