summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-11-17 18:14:36 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-11-17 18:14:36 -0800
commit93cac5dcf2ec6f3816d3b2a8c20b2c5fa786ac0f (patch)
tree3311a1d6fbc5338237915d20ec6e3a8aea1fa7f5 /PKGBUILD
parentUpdated to 63.0.1 (diff)
downloadfirefox-esr-93cac5dcf2ec6f3816d3b2a8c20b2c5fa786ac0f.tar.xz
Updated to 63.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a74df5..93b36d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
# Arch version doesn't support alsa
pkgname=firefox
-pkgver=63.0.1
+pkgver=63.0.3
bz2ver=$(echo $pkgver | sed 's/\./_/g')
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
@@ -20,32 +20,28 @@ arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
- ffmpeg nss hunspell-en_CA sqlite ttf-font alsa-lib libvpx icu)
+ ffmpeg nss ttf-font alsa-lib sqlite libvpx icu)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust mercurial clang llvm gtk2
python python2-psutil cbindgen)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
- 'speech-dispatcher: Text-to-Speech')
+ 'speech-dispatcher: Text-to-Speech'
+ 'hunspell-en_CA: Spell checking, Canadian English')
options=(!emptydirs !makeflags !strip)
source=(firefox-$pkgver.tar.bz2::https://hg.mozilla.org/releases/mozilla-release/archive/FIREFOX_${bz2ver}_RELEASE.tar.bz2
$pkgname.desktop firefox-symbolic.svg
- 0001-Keep-mozilla-release-building-with-newer-cbindgen-ve.patch
vendor.js
package-manifest.diff)
-sha256sums=('87eb045d6eb9d46f76a96d91b2138d584f3dc88f1e6e6989774bc988dc14197d'
+sha256sums=('8bd500c8e4eaa259252e09e5189f9817da971054904236c72be843b57a2bdc7a'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- 'a1e523f830f28217e050991062358c91be254e21732a6391449a8c0e3e0de77f'
- '08f344956146b273dabdfe2451a21c216ed76eb3cfad2e2b3f018f3991d0bb80'
+ '4c746f1aff4fc2804f642598f199f4d2a3020605ccfa366e89d7da2d91c299e6'
'28e5db73f04ce8794f68822deda5512c64f832e542ad58fb7e40cad9e4785664')
prepare() {
mkdir mozbuild
cd mozilla-release-FIREFOX_${bz2ver}_RELEASE
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1503401
- patch -Np1 -i ../0001-Keep-mozilla-release-building-with-newer-cbindgen-ve.patch
cat >$srcdir/mozilla-release-FIREFOX_${bz2ver}_RELEASE/.mozconfig <<END
ac_add_options --enable-application=browser