summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-12-14 03:04:40 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-12-14 03:04:40 -0800
commitb1ef70bcbff3985d393929d5d9b59691f1de4c53 (patch)
tree6fe2005b06e5ae285370e75053caa665fe4311b9 /PKGBUILD
parentUpdated to 64.0 | Commented out system addon removal until the workaround can... (diff)
downloadfirefox-esr-b1ef70bcbff3985d393929d5d9b59691f1de4c53.tar.xz
Use python3 makedepends | Clean up whitespace in vendor.js
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0f6c36..0099338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@
# Arch version doesn't remove system addons
# Arch version lacks privacy and security by default
# Arch version doesn't support alsa
+# Arch version makepdepends on python2
pkgname=firefox
pkgver=64.0
@@ -21,9 +22,9 @@ license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss ttf-font alsa-lib sqlite libvpx icu)
-makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+makedepends=(unzip zip diffutils python-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm gtk2
- python nodejs python2-psutil cbindgen)
+ python nodejs python-psutil cbindgen)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'speech-dispatcher: Text-to-Speech'
@@ -35,7 +36,7 @@ source=(firefox-$pkgver.tar.bz2::https://hg.mozilla.org/releases/mozilla-release
sha256sums=('5f249e8edcced5531b86a330bf90938bfe414d21a03c25a035b52aeab987870c'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '98b5560aa855fe25f5127adb1eea3fb88681fd19507a062371429bd2bd735e93')
+ '3b71a4ae3a1b4a598d5d4f82f83d2941277c8f59064231ffc1dff61415763d6f')
prepare() {
mkdir mozbuild
@@ -126,7 +127,6 @@ build() {
package() {
cd mozilla-release-FIREFOX_${bz2ver}_RELEASE
DESTDIR="$pkgdir" ./mach install
- # find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
install -Dm644 "$srcdir/vendor.js" "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
local shortver=$(echo $pkgver | cut -d'.' -f1,2)