summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-10-24 02:18:24 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-10-24 02:18:24 -0700
commitc6c52b7460d12a71afc2214044f519271c38fb52 (patch)
tree1bdc750e69944d74c1e45ff746038f9bb51ee147 /PKGBUILD
parentUpdated to 62.0.3 (diff)
downloadfirefox-esr-c6c52b7460d12a71afc2214044f519271c38fb52.tar.xz
Updated to 63.0 | Disabled nodejs | vendor.js updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60dad8b..ed0adec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,17 +12,18 @@
# Arch version doesn't support alsa
pkgname=firefox
-pkgver=62.0.3
+pkgver=63.0
bz2ver=$(echo $pkgver | sed 's/\./_/g')
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
-depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell-en_CA sqlite ttf-font alsa-lib libvpx icu)
-makedepends=(unzip zip diffutils python2 yasm mesa imake inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm gtk2 python)
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss hunspell-en_CA sqlite ttf-font alsa-lib libvpx icu)
+makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+ xorg-server-xvfb autoconf2.13 rust mercurial clang llvm gtk2
+ python python2-psutil cbindgen)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'speech-dispatcher: Text-to-Speech')
@@ -31,13 +32,14 @@ source=(firefox-$pkgver.tar.bz2::https://hg.mozilla.org/releases/mozilla-release
$pkgname.desktop firefox-symbolic.svg
vendor.js
package-manifest.diff)
-sha256sums=('a7eb49a538cf26e44edd9ff2e42b0cf9e29296b5cdc59778f027cba56c96451c'
+sha256sums=('0b2c5dd6d74a742efbad9406c7c28a1194b3375687ea9dfd7b7f8274b1ee81ec'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '315e818edd8b002ba2f9bf1baddf064b0b5fa694365789e52fc26cf339de908a'
+ 'e93611c0a0a20da6e28c3fc5c59398cdee91e52a64888c60a38783cf555817d6'
'28e5db73f04ce8794f68822deda5512c64f832e542ad58fb7e40cad9e4785664')
prepare() {
+ mkdir mozbuild
cd mozilla-release-FIREFOX_${bz2ver}_RELEASE
@@ -46,7 +48,6 @@ ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
@@ -60,15 +61,15 @@ export MOZ_ADDON_SIGNING=0
export MOZ_REQUIRE_SIGNING=0
# System libraries
-ac_add_options --with-system-zlib
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-sqlite
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
+ac_add_options --with-system-zlib
# Features
ac_add_options --enable-alsa
@@ -77,6 +78,7 @@ ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-eme
ac_add_options --disable-gconf
+ac_add_options --disable-nodejs
ac_add_options --disable-tests
ac_add_options --disable-updater
ac_add_options --disable-webrtc
@@ -105,6 +107,8 @@ build() {
mkdir --parents $srcdir/mozilla-release-FIREFOX_${bz2ver}_RELEASE/obj-x86_64-pc-linux-gnu/dist/bin/browser/features
# export MOZ_SOURCE_REPO="$_repo"
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
./mach build
./mach buildsymbols