summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-10-02 18:43:39 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-10-02 18:43:39 -0700
commitce995602baf2ca387bf5cd581611ba49f66dd921 (patch)
treeb823b2322f69d7cc1680936da6f07374f8bb296b /PKGBUILD
parentRemoved deprecated settings from vendor.js (diff)
downloadfirefox-esr-ce995602baf2ca387bf5cd581611ba49f66dd921.tar.xz
Updated to 62.0.2 | Maintainer logic | vendor.js changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3495d3f..0d97bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,15 @@
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
+# # I maintain this because:
+# Arch version uses git
+# Arch version requires signed addons
+# Arch version doesn't remove system addons
+# Arch version lacks privacy and security by default
+# Arch version doesn't support alsa
+
pkgname=firefox
-pkgver=62.0
+pkgver=62.0.2
bz2ver=$(echo $pkgver | sed 's/\./_/g')
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
@@ -14,7 +21,7 @@ license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
nss hunspell-en_CA sqlite ttf-font alsa-lib libvpx icu)
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
+makedepends=(unzip zip diffutils python2 yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust mercurial clang llvm gtk2 python)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -24,15 +31,16 @@ source=(firefox-$pkgver.tar.bz2::https://hg.mozilla.org/releases/mozilla-release
$pkgname.desktop firefox-symbolic.svg
vendor.js
package-manifest.diff)
-sha256sums=('81fc299be89e6f34c09209e89cebacf47c5c86395f24026ee17ad3d53d9c626c'
+sha256sums=('e26e833f7b84211820d25b359f89aad7baa1c92c9f5e058e1981829a1db17c8f'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- 'b053099d48da2f6b9d70dc6ff37f39e4f8337faab1a064f92c0d79e90985ad6b'
+ '315e818edd8b002ba2f9bf1baddf064b0b5fa694365789e52fc26cf339de908a'
'28e5db73f04ce8794f68822deda5512c64f832e542ad58fb7e40cad9e4785664')
prepare() {
cd mozilla-release-FIREFOX_${bz2ver}_RELEASE
+
cat >$srcdir/mozilla-release-FIREFOX_${bz2ver}_RELEASE/.mozconfig <<END
ac_add_options --enable-application=browser
@@ -68,6 +76,7 @@ ac_add_options --disable-pulseaudio
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-eme
+ac_add_options --disable-gconf
ac_add_options --disable-tests
ac_add_options --disable-updater
ac_add_options --disable-webrtc
@@ -95,7 +104,7 @@ build() {
cd mozilla-release-FIREFOX_${bz2ver}_RELEASE
mkdir --parents $srcdir/mozilla-release-FIREFOX_${bz2ver}_RELEASE/obj-x86_64-pc-linux-gnu/dist/bin/browser/features
- export MOZ_SOURCE_REPO="$_repo"
+# export MOZ_SOURCE_REPO="$_repo"
./mach build
./mach buildsymbols