summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-05-03 11:07:26 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-05-03 11:07:26 -0700
commitebb5a83ed3818367dad34f6d83ef16c322ae4dbf (patch)
tree426c3aec58ef89f1858e17d7760bf874316dd776 /PKGBUILD
parentUpdated to 49.0.1 (diff)
downloadfirefox-esr-ebb5a83ed3818367dad34f6d83ef16c322ae4dbf.tar.xz
Updated to 59.0.2 | vendor.js updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ba1e4c..4806d9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox
-pkgver=59.0.1
-pkgrel=1
+pkgver=59.0.2
+pkgrel=3
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@@ -18,23 +18,27 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech')
-options=(!emptydirs !makeflags !strip !debug)
+options=(!emptydirs !makeflags !strip)
_repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
+ 0001-Bug-1435212-Add-support-for-FFmpeg-4.0.-r-bryce.patch.xz
$pkgname.desktop firefox-symbolic.svg
no-crmf.diff
- vendor.js)
+ vendor.js)
sha256sums=('SKIP'
+ '8422030440032535d918844263fbd92d39bff207acb5fff55ed0afee38bcf582'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
'02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
- '227de32467f36e30e390da16e183ea1d83d1f49c2fe856661a9b5dddf1fe4389')
+ '3aabcc9ac0389e13b0f98c86f0c58b248e69bb3e9d83747619bce8a00602824b')
prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
cd mozilla-unified
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1435212
+ patch -Np1 -i ../0001-Bug-1435212-Add-support-for-FFmpeg-4.0.-r-bryce.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff
@@ -52,7 +56,7 @@ ac_add_options --enable-rust-simd
# Branding
ac_add_options --disable-official-branding
ac_add_options --enable-update-channel=release
-ac_add_options --with-distribution-id=
+ac_add_options --with-distribution-id=org.archlinux
export MOZ_TELEMETRY_REPORTING=0
export MOZ_ADDON_SIGNING=0
export MOZ_REQUIRE_SIGNING=0
@@ -80,6 +84,12 @@ ac_add_options --disable-updater
ac_add_options --disable-webrtc
END
+
+ # Disable various components at the source level
+ sed -i 's|[;]1|;0|' toolkit/components/telemetry/TelemetryStartup.manifest || die "failed break telemetry startup"
+ sed -i 's|[;]1|;0|' browser/experiments/Experiments.manifest || die "failed to break ExperimentsService"
+ sed -i '/pocket/d' browser/extensions/moz.build || die "failed to wipe pocket"
+ sed -i '/activity-stream/d' browser/extensions/moz.build || die "failed to wipe activity-stream"
}
build() {