summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD69
1 files changed, 7 insertions, 62 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8dfac67..a175b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,6 @@
# Arch version enables debug symbols
# Arch version lacks privacy and security by default
-_modclang=1
_modpgo=0
_pkgname=firefox
@@ -48,6 +47,7 @@ provides=(firefox)
source=(
"https://archive.mozilla.org/pub/$_pkgname/releases/$_pkgver/source/$_pkgname-$_pkgver.source.tar.xz"{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
+ 0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch
$pkgname.desktop
identity-icons-brand.svg
distribution.ini
@@ -64,11 +64,12 @@ source=(
b2sums=('f4b7a45c87de4bf8758bd6582cac93a2901aff38dbf7a0cdef646af2bc7e474858af28ed904701305866b06d1a7c1aa42681c8f0e48512b1c72ab00cc99d9f2a'
'SKIP'
'cfd09442eb344fb80b2233da86a101082926b9942849d988d0e43cac4cb6c15690dc8eae42514e114260b712c206cacd81f773e401cf8f861ee4b805fb872643'
+ '3b9cc149b520375a12dec279f67e9d0abc527d92e000b848a78628f5afacd5b1883e16b5698e78db18378cb64851ca61bac2ccb4769395e76638578cda77998f'
'1c3af4cc5199cf7b9f3aad9ceab98b3e8a3dc0d38f50896ed2f32ac648f1e904a1cdda5da559964885989edbfab4c4bf65448e9a0f71d946c77ec0ab5a6aff4c'
'63a8dd9d8910f9efb353bed452d8b4b2a2da435857ccee083fc0c557f8c4c1339ca593b463db320f70387a1b63f1a79e709e9d12c69520993e26d85a3d742e34'
'877eda442eb4730600dccf209a6e961ad3122ab456bbfda4ff041e8493ebaaf96224ac218360931259ff4214482f6bf65b3a3052f977ade1a274f38ffd859535'
'645e9438585624c5ae20cd5fd8e59c912734ea6e5bbfb33ddeb226f3b88e1b443c334684b0445b748f6cbe64506acf8710f265b87efa6bfc2f0aa5623680aed0'
- '1c7ac58af8b817067c7d79ffef8d9100f513d77f4fc1a2bce2684ff8d8d3cbc3d37b31865c7e5d873fd71d4649374bbd25ca08166d8afb25ffbd597759655063'
+ '0f8e203bda791428acf526481959978d26e988d34b5f0490c2f9ac3307feefaf7ec7511ba4647c3f254c86288a7265476df860dee38ae5a7aaba9e264b1fe4bc'
'1dce1277c0c8b83089551057ed61c8794aa65242d0c19573dab96081f00b1042af73fbc0a40ba49dfa31eff46f4636ffd985cf8e6bd28db614a639ca6c11c74e'
'379adf3726664668f6167eaeab35dec40342d9288ff081d22a8363f163ab0945b17ce69e7d4276a31e99e56f690afa070c410c51a5060ed835356fd216256e7b')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases
@@ -79,43 +80,21 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+ patch -Np1 -i ../0002-Bug-1745560-Add-missing-stub-for-wl_proxy_marshal_fl.patch
-
- if [ "${_modclang}" == "0" ]; then
- # Apply gcc lto patches
- patch -Np1 -i ../arc4_enable-lto-for-gcc.patch
- patch -Np1 -i ../firefox-gcc-build.patch
- fi
-
- if [ "${_modclang}" == "0" ] && [ "${_modpgo}" == "1" ]; then
- # Apply gcc pgo patches
- patch -Np1 -i ../arc4_enable-pgo-for-gcc.patch
- patch -Np1 -i ../pgo.patch
- fi
-
- if [ "${_modclang}" == "1" ] && [ "${_modpgo}" == "1" ]; then
+ if [ "${_modpgo}" == "1" ]; then
# Add the custom mozconfig for clang pgo
cp $srcdir/mozconfig.in.clang $srcdir/${_pkgname}-${pkgver}/.mozconfig
cat >$srcdir/${_pkgname}-${pkgver}/.mozconfig - <<END
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
ac_add_options --enable-profile-generate=cross
END
- elif [ "${_modclang}" == "1" ] && [ "${_modpgo}" == "0" ]; then
+ elif [ "${_modpgo}" == "0" ]; then
# Add the custom mozconfig for clang
cp $srcdir/mozconfig.in.clang $srcdir/${_pkgname}-${pkgver}/.mozconfig
cat >$srcdir/${_pkgname}-${pkgver}/.mozconfig - <<END
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
END
- elif [ "${_modclang}" == "0" ] && [ "${_modpgo}" == "1" ]; then
- # Add the custom mozconfig for gcc pgo
- cp $srcdir/mozconfig.in.gcc $srcdir/${_pkgname}-${pkgver}/.mozconfig
- cat >$srcdir/${_pkgname}-${pkgver}/.mozconfig - <<END
-mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
-ac_add_options --enable-profile-generate=cross
-END
- else
- # Add the custom mozconfig for gcc
- cp $srcdir/mozconfig.in.gcc $srcdir/${_pkgname}-${pkgver}/.mozconfig
fi
# MOZ_TELEMETRY_REPORTING only applied correctly when set in this override file
@@ -161,7 +140,7 @@ build() {
ulimit -n 4096
- if [ "${_modclang}" == "1" ] && [ "${_modclangpgo}" == "1" ]; then
+ if [ "${_modpgo}" == "1" ]; then
# clang does not support -fstack-clash-protection, so remove it
#export CFLAGS="$(echo $CFLAGS | sed 's/ -fstack-clash-protection//' - )"
#export CXXFLAGS="$(echo $CXXFLAGS | sed 's/ -fstack-clash-protection//' - )"
@@ -198,40 +177,6 @@ ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
END
./mach build
- elif [ "${_modclang}" == "0" ] && [ "${_modpgo}" == "1" ]; then
-
- # Do 3-tier PGO
- echo "Building instrumented browser..."
- ./mach build
-
- echo "Profiling instrumented browser..."
- ./mach package
- LLVM_PROFDATA=llvm-profdata \
- JARLOG_FILE="$PWD/jarlog" \
- xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
- ./mach python build/pgo/profileserver.py
-
- stat -c "Profile data found (%s bytes)" merged.profdata
- test -s merged.profdata
-
- stat -c "Jar log found (%s bytes)" jarlog
- test -s jarlog
-
- echo "Removing instrumented browser..."
- ./mach clobber
-
- echo "Building optimized browser..."
- # Add the custom mozconfig
- cp $srcdir/mozconfig.in.gcc $srcdir/${_pkgname}-${pkgver}/.mozconfig
- cat >.mozconfig - <<END
-mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
-ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
-ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
-ac_add_options --enable-lto=cross
-ac_add_options --enable-profile-use=cross
-END
- ./mach build
-
else
echo "Building optimized browser..."
xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" ./mach build