summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD82
1 files changed, 57 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be4d0af..b7c12cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,9 +22,9 @@ _modpgo=0
_pkgname=firefox
pkgname=${_pkgname}-esr
-pkgver=102.0.1
+pkgver=102.2.0
_pkgver=${pkgver}esr
-pkgrel=1.2
+pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
@@ -37,29 +37,49 @@ makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
wasi-compiler-rt wasi-libc wasi-libc++ wasi-libc++abi
# Use as many system python modules as possible
python-aiohttp python-appdirs python-async-timeout python-attrs
- python-blessings python-cbor2 python-certifi python-chardet python-click
- python-colorama python-cookies python-cram
- python-distro python-ecdsa
+ python-blessings
+ python-cbor2 python-certifi python-chardet python-click python-colorama python-cookies python-cram
+ python-ecdsa
python-idna python-importlib-metadata
- python-iso8601 python-jaraco.context python-jaraco.functools python-jaraco.text
- python-jsonschema python-markupsafe
- python-mohawk python-more-itertools python-multidict
- python-nspektr python-ordered-set python-packaging python-pathspec python-pip
- python-ply python-pyasn1 python-pyasn1-modules
- python-pyparsing python-pyrsistent python-pytoml python-yaml
+ python-iso8601
+ python-jaraco.context python-jaraco.functools python-jsonschema
+ python-markupsafe python-mohawk python-more-itertools python-multidict
+ python-nspektr
+ python-ordered-set
+ python-packaging python-pathspec python-pip python-ply python-pyasn1 python-pyasn1-modules python-pyparsing python-pyrsistent python-pytoml
python-requests python-requests-unixsocket python-responses python-rsa
- python-setuptools python-six
- python-tomli python-tqdm python-trove-classifiers python-typing-extensions
- python-urllib3 python-validate-pyproject python-voluptuous python-wheel
- python-yarl python-zipp python-zstandard)
-# # Firefox explicitly requires these python modules be outdated
-# python-psutil)
-# # Arch lacks these python modules
-# python-compare-locales python-diskcache python-esprima
-# python-fluent.migrate python-fluent.syntax python-idna-ssl python-Jinja2 python-jsmin
-# python-json-e python-mozilla-version python-pip-tools python-redo python-sentry-sdk
-# python-slugid python-taskcluster python-taskcluster-taskgraph python-taskcluster-urls
-# python-yamllint)
+ python-six
+ python-tomli python-tqdm python-trove-classifiers
+ python-urllib3
+ python-validate-pyproject python-voluptuous
+ python-wheel
+ python-yaml python-yarl
+ python-zipp python-zstandard
+ )
+# # Firefox explicitly requires these python modules be outdated:
+# python-psutil
+
+# # Firefox explicitly forces these modules from bundled regardless of set system modules:
+# python-typing-extensions
+
+# # As a result of typing-extension being force bundled, these must also be bundled:
+# python-pydantic
+# # And as pydantic must be bundled, so must all other modules that require pydantic:
+# python-inflect <- python-jaraco.text <- python-setuptools <- python-distro
+
+# # Arch lacks these python modules:
+# python-compare-locales
+# python-diskcache
+# python-esprima
+# python-fluent.migrate python-fluent.syntax
+# python-idna-ssl
+# python-Jinja2 python-jsmin python-json-e
+# python-mozilla-version
+# python-pip-tools
+# python-redo
+# python-sentry-sdk python-slugid
+# python-taskcluster python-taskcluster-taskgraph python-taskcluster-urls
+# python-yamllint
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'alsa-utils: ALSA support'
@@ -77,6 +97,8 @@ source=(
"https://archive.mozilla.org/pub/$_pkgname/releases/$_pkgver/source/$_pkgname-$_pkgver.source.tar.xz"{,.asc}
cbindgen-0.24.0.diff
zstandard-0.18.0.diff
+ update-packed_simd.diff
+ arc4random.diff
$pkgname.desktop
identity-icons-brand.svg
distribution.ini
@@ -90,10 +112,12 @@ source=(
arc4_remove-health-reporting.patch
arc4_remove-system-addons.patch
)
-sha512sums=('ce804fa4e5dda3b8c4c7937f18994a184b0eb7d8fb9484dc924d04d3213ee3daf018141f91703daed6d060a99bfc5d915186db10a4ddcf220c2ea43e369e58df'
+sha512sums=('06d753867ccfe1b2c79148cc60bc816b47a2abfa98219808868e9028bef1763d982ef7012698d06b8959cce79163d7926baf5f9d5ca9daa18c51fbf0efc59993'
'SKIP'
'3526402ccae1f0428f2e45bae8d0b2cb909ac2698bc3508b692b827839ccb21203ce414206039776f6ce946fc53e636290b7870e9886284d5e9d1e8ad050aac9'
'c949cf492bc93b6f3f1f827744e0f39e555c518434c8e73e27143a769b0d123fe4ba2cae07b7b7e7b594f8da43383d4fb4cd28b6b52e0d3e7a985afbadfb3d04'
+ '1377b852680667b378ae97e073149230067ad2dc03e4dd53ca59239e6f8542156c5e27239504a0540f0b1254fc9e43c93cf2575ba0bcfcb2ad74f37bc4961c5a'
+ '9cbc214c3ae7b93ef6c0573194dc7600dd0b4bb6f2653693d75b08475b7c3d65f6a181055060848143b488207c39af3fdb7382bb45de5264b2daedcb62bf97f2'
'46b76cc688099bbd4124c0b94eea45c1c43a95e1aab9ea8ff6b9c29cdefe383f7a4885f09ceef34e5e6ee2f1f589024b575352b26512feca703c68a48dc5818f'
'b579b73176c72a5ecf36e3f63bba08fdb8041ae99d54e5cab906660fed6a9cf2311f7ca1ec1649e451cc6d5a4b1e6060b974b1d7befe9c8df3c5a89c50383c17'
'b075df0ddbcbc5eed5ef9d02d859da8f104fe507808050e9a990c8f3aeb01645b77972a3af07bd2427680449104af623065d97fbbc40fc42aea0b5ba931e8324'
@@ -101,10 +125,12 @@ sha512sums=('ce804fa4e5dda3b8c4c7937f18994a184b0eb7d8fb9484dc924d04d3213ee3daf01
'6c933ebfd683b955a3deb2f47b13f582ccd40f57e1164a0c821a65c4bc6040a1e0baf3a4aab1354c3e0ceeb4f3fab53612e54dfd0f56d320cf0a64bf3c270526'
'34b90b6033d8c6196600aa820f8d5038ef506f07a6c8b90bc1b5691c47172df8778757aa9db68116bef9ced2d5592320e6d7a47cfb20cf133ba5757739d9968d'
'e3e095eaa6427d1f8a392b16789ba51c1f13ec8a26f9128eada7fbf190ca8a47c92453e6cfd89676138869e7fdac765ff83cde01cc8b02d1de914c7eb4b1b22e')
-b2sums=('f0caff349ffc28d10f3094957cb93d54ed4bac4a19532353dd4f09314435227af55264715d4d2cedfa01882d779ca92f9e3f600cea664e45972a544445075a23'
+b2sums=('00975ffc02a11619d971731d53fbd480e9e6940d2cb9bd77c529b790e9734db85cc48b4e70d5acf447d221620feb8e9d9b8d129d07f270acd0d388574b129ee4'
'SKIP'
'b9d57be48fcbddcaf55b01648987102ba0242905eb576aa7e85ee15e4bcb9666255fc258348c82ec321e70f7ce3e466c95faa41defb386b9dae74673a7117d43'
'b66218c1388f5cb549f4084273f56cca53311bff948c041ccb09745cf483a66973b5419950d9a9df7c9813005842300e05358f4004978f3bdabecc82b946809f'
+ '2309b32cff7b95b66e4a2acd41b12bedf8a86c9b7b83e45a663ac4f8bf04be422ac4af73f8101e1dacca31c2938c4372eddeaaebc11a8ad47bb4bf30c438c753'
+ '8a8d084b33f884fbff779479348457394fa89c21c544532be46b4e0c78e01d570d2b8f00ba48504a193bf70000cace4edf454792f4e73432fc7f2de5c212d835'
'1c3af4cc5199cf7b9f3aad9ceab98b3e8a3dc0d38f50896ed2f32ac648f1e904a1cdda5da559964885989edbfab4c4bf65448e9a0f71d946c77ec0ab5a6aff4c'
'63a8dd9d8910f9efb353bed452d8b4b2a2da435857ccee083fc0c557f8c4c1339ca593b463db320f70387a1b63f1a79e709e9d12c69520993e26d85a3d742e34'
'877eda442eb4730600dccf209a6e961ad3122ab456bbfda4ff041e8493ebaaf96224ac218360931259ff4214482f6bf65b3a3052f977ade1a274f38ffd859535'
@@ -123,6 +149,12 @@ prepare() {
# Unbreak build with python-zstandard 0.18.0
patch -Np1 -i ../zstandard-0.18.0.diff
+
+ # Unbreak build with simd
+ patch -Np1 -i ../update-packed_simd.diff
+
+ # Fix arc4random
+ patch -Np1 -i ../arc4random.diff
if [ "${_modpgo}" == "1" ]; then
# Add the custom mozconfig for clang pgo