summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-11-21 20:17:43 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-11-21 20:17:43 -0800
commitc7d81c21663e3cee1ab751da688b7d0cbf2acc3a (patch)
tree4cce738804594af0593b724445ab9306fc057bd1 /PKGBUILD
parentUpdated to 70.0.1 (diff)
downloadfirefox-c7d81c21663e3cee1ab751da688b7d0cbf2acc3a.tar.xz
Rebuild for libicu
Fixes for rust 1.39 and python 3.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56290aa..521acba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,9 @@ _modclang=0
pkgname=firefox
pkgver=70.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
-arch=(x86_64)
+arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 libxt startup-notification mime-types dbus-glib ffmpeg
@@ -41,6 +41,9 @@ options=(!emptydirs !makeflags)
conflicts=(firefox-esr)
source=("https://archive.mozilla.org/pub/$pkgname/releases/$pkgver/source/$pkgname-$pkgver.source.tar.xz"{,.asc}
no-relinking.patch
+ 0001-Update-bindgen.patch
+ 0002-Bug-1212502-Switch-mozinfo-to-using-the-distro-packa.patch
+ 0001-Bug-1593167-ensure-that-loadable-certs-are-loaded-wh.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop
distribution.ini
@@ -54,6 +57,9 @@ source=("https://archive.mozilla.org/pub/$pkgname/releases/$pkgver/source/$pkgna
sha256sums=('f2e9bb26af7682b31e82fdfc3a4b3e04fd1caa8b004469ea608185d33e35691b'
'SKIP'
'2dc9d1aa5eb7798c89f46478f254ae61e4122b4d1956d6044426288627d8a014'
+ '832d895c90d346fe4acf25b8b8ba9a62bea595fe5fcdeaf545c8e952393993fc'
+ '58890388e02af41055e1ec9797b7c094dee499a5219dc9c532c6cfccf2cce972'
+ 'c0e8176d7382649b7423d809fd586b01b50e95df816ef34237683c2598802c2f'
'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
'a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33'
'0ba4d1a619a3a5750a5a48c6bff8c6a69d3aa4be4c303032c5979ab5f68db208'
@@ -72,6 +78,13 @@ prepare() {
# Avoid relinking during buildsymbols
patch -Np1 -i ../no-relinking.patch
+
+ # Make it compile with Rust 1.39 and Python 3.8
+ patch -Np1 -i ../0001-Update-bindgen.patch
+ patch -Np1 -i ../0002-Bug-1212502-Switch-mozinfo-to-using-the-distro-packa.patch
+
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1593167
+ patch -Np1 -i ../0001-Bug-1593167-ensure-that-loadable-certs-are-loaded-wh.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch