summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-01-30 03:21:53 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-01-30 03:21:53 -0800
commitfbb593caa947b29f34f0abdcf6a9cb0bbc26dc18 (patch)
tree9e331c5bb2f44a9fa637c1ef8b4dbad0cafbd8bf /PKGBUILD
parentUpdated to 64.0.2 (diff)
downloadfirefox-fbb593caa947b29f34f0abdcf6a9cb0bbc26dc18.tar.xz
Updated to 65.0 | Enabled svg by default due to mulitple security addons requiring it
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e475762..9972d72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
# Arch version enables debug symbols
pkgname=firefox
-pkgver=64.0.2
+pkgver=65.0
bz2ver=$(echo $pkgver | sed 's/\./_/g')
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
@@ -26,7 +26,7 @@ depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss ttf-font alsa-lib sqlite libvpx icu)
makedepends=(unzip zip diffutils python-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm gtk2
- python nodejs python-psutil cbindgen)
+ python nodejs python-psutil cbindgen nasm)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'speech-dispatcher: Text-to-Speech'
@@ -37,12 +37,12 @@ source=(firefox-$pkgver.tar.bz2::https://hg.mozilla.org/releases/mozilla-release
vendor.js
moz.configure.diff
package-manifest.diff)
-sha256sums=('e86c6354cd74e734ec1f12bdfda77c4614aa3d4fe3b14264f4b817e5dc7418d9'
+sha256sums=('5f1f27aa004d94504993e18e2a96edebd0178c7da9f9c00474dda468bb876759'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '23104566d3497b0998f8fe3ad2a4c78b3389520da5bdd27b7176db7eb82e9d95'
+ '5cc920b4f229af826a75b3234563174f2477be9b2aee585fd30a7389ef7be35d'
'ad8a270e1b2affb098440f82517c3952207b28ebf604fef695dad3e29a5ba30e'
- '02f9b14dc547fa059112e693aece6d6f416708d8f00f1b1d825b8f0692ac72a3')
+ '927e400d6920b98d2fe7db2b6498f195135909a76e0da49441223956364d8227')
prepare() {
# mkdir mozbuild
@@ -68,8 +68,6 @@ export RANLIB=llvm-ranlib
ac_add_options --enable-official-branding
ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=org.artixlinux
-export MOZ_ADDON_SIGNING=0
-export MOZ_REQUIRE_SIGNING=0
# System libraries
ac_add_options --enable-system-ffi
@@ -97,6 +95,8 @@ ac_add_options --disable-webspeechtestbackend
ac_add_options --disable-webrtc
mk_add_options MOZ_MAKE_FLAGS="-j4"
+export MOZ_ADDON_SIGNING=0
+export MOZ_REQUIRE_SIGNING=0
END