summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 651ac9f..ba55c02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer (Arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Aqua-sama <aqua@iserlohn-fortress.net>
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
@@ -18,7 +18,7 @@ _modclang=0
#_modclang=1 # FIXME
pkgname=firefox
-pkgver=78.0.2
+pkgver=79.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64 aarch64)
@@ -28,7 +28,7 @@ depends=(gtk3 libxt mime-types dbus-glib ffmpeg ttf-font libpulse alsa-lib
bzip2 libffi icu libjpeg-turbo libevent libvpx nspr nss pixman libpng sqlite libwebp zlib)
makedepends=(unzip zip diffutils yasm mesa imake inetutils xorg-server-xvfb
autoconf2.13 rust clang llvm jack gtk2 nodejs cbindgen nasm
- python-setuptools python-psutil)
+ python-setuptools python-psutil lld)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'alsa-utils: ALSA support'
@@ -43,6 +43,7 @@ conflicts=(firefox-esr)
source=(
"https://archive.mozilla.org/pub/$pkgname/releases/$pkgver/source/$pkgname-$pkgver.source.tar.xz"{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
+ bug1654465.diff
$pkgname.desktop
distribution.ini
mozconfig.in
@@ -53,14 +54,15 @@ source=(
arc4_remove-health-reporting.patch
arc4_remove-system-addons.patch
)
-b2sums=('ecddeee641a61409cf603afe97c3e97854700d3858bef8ec0d09c58b39023162e2939a3619481c1b9ac7f5b98bf6c7082108db3c9736332f2e30a6ac14b34b2c'
+b2sums=('6a21cf8b0d53db067b020b969180a04233171113c0a4d64e5c3599fb2c991705e4faf7995acab578c7683f30dc074c834e36d23a84c5869ef7f015f86eebb871'
'SKIP'
'e4cf5d0ddd2c7271f1723b5c313f0aa8a7bf2242fb301ceba1ab5a4dca655ca7b9461d0aaebe5eaccf84b2f7a4c4199cbb0c18eab2bdaff273fcb730ec27219e'
+ 'a71968df168ba78eb46323177f5223d9d9f68325330751ff713e47c0d35e3bb366610cf0a8e3068421ea844b7fadff7a987cc93495a371aa9ba08695ee8ab262'
'e18f2c22e394ca3b6758bc130245b254947e4d15921be3da443d6d7c3c4b0d22ead1b39fbc10a4f896edd19e2a1dffbd1cbb34dc4beb0621a6ddb70ccc53b3a7'
'877eda442eb4730600dccf209a6e961ad3122ab456bbfda4ff041e8493ebaaf96224ac218360931259ff4214482f6bf65b3a3052f977ade1a274f38ffd859535'
'6e351d0be6e6c82512ac0b6e1aad0111c1eeeb947d9e411733618cb531533f857d849b7759e0e5282279bdbfbdd62fa0b1e4af500ede06f20278c6c248e5816f'
- '97bc0b13fc9633cca9f380a532072c3b1295ed36c0516376b246fad2be43baa375562812723ab85b545b1c9ee55dfd816da2d82b72eea13aa41aafec9c65da9d'
- 'cc92ae16f103e8cb18e1fbed4ba64dfda14c4ee5da4121b48740ac030536a0c9f4c77c52aa5e30b47a2274c811846d9b8a045213fc8ea0254af18ae4659a00ee'
+ 'aa87016dabc182a4da3db1f29f4a6b274095be883febf848ddbe86615639b6a85f12b2c78ce6b18bba18516982330fb775083f4bab330738d95ee26d70f02dfa'
+ 'ffb7ca117004a084b1bd7baed6a11b0914ec391459d662fc8887edc3206eb25c41b09f713e9bfe0ed474333d9537295842b0617dd29e9ce222fde548cd9111aa'
'1e8cdc2968a78fa395b77b654496dbbf21d37308a7fd560ab5cff8dc092d9b5123c374af8a5a18dec7fd2a053f411a1478ebfd928365208d22042391da444b4b'
'087ea758132905cab848e3a13a13537b42f70ba3a8bfd1ef4e2933d3e874e94038b50ee583b9e7e0c7b7cc7c2cf570f7f613b661f47121b7bf207f433b939f3d'
'4c0f100c52721f9d9a840d7de1f1d5310578ef7fbc350c62341d96b2af23d8bcb774a289429693153635964860cbb05074149bf043941dec87a1d86655b4d4b6'
@@ -74,6 +76,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1654465
+ patch -Np1 -i ../bug1654465.diff
+
if [ "${_modclang}" != "1" ]; then
# Apply gcc pgo patches
patch -p0 $srcdir/${pkgname}-${pkgver}/security/sandbox/linux/moz.build $srcdir/arc4_enable-pgo-for-gcc.patch
@@ -142,15 +147,11 @@ build() {
xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
./mach python build/pgo/profileserver.py
- if [[ ! -s merged.profdata ]]; then
- echo "No profile data produced."
- return 1
- fi
+ stat -c "Profile data found (%s bytes)" merged.profdata
+ test -s merged.profdata
- if [[ ! -s jarlog ]]; then
- echo "No jar log produced."
- return 1
- fi
+ stat -c "Jar log found (%s bytes)" jarlog
+ test -s jarlog
echo "Removing instrumented browser..."
./mach clobber