summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f85cb58..fa56fb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _testgcc=0
pkgname=firefox
pkgver=83.0
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
@@ -44,6 +44,7 @@ conflicts=(firefox-esr)
source=(
"https://archive.mozilla.org/pub/$pkgname/releases/$pkgver/source/$pkgname-$pkgver.source.tar.xz"{,.asc}
0001-Use-remoting-name-for-GDK-application-names.patch
+ 0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
$pkgname.desktop
distribution.ini
mozconfig.in
@@ -58,7 +59,8 @@ source=(
)
b2sums=('b3a805288f4d644f7375c78ebe771c26d59c57f6aad71877abbfe60563c06af5f162b8894cb624cec12a5c72542ffad97e6f8f0cfc3fba0506d4e246a41911e1'
'SKIP'
- '52a5e76ecdc564b0dcd179f8b6d2e0bc14f4596df3434b32d055f35b252fadec78897356b9c0bed50cc397637e9a51af1ab59409e45605211a778804fd4f79a2'
+ 'c83065fa6eab83c4b74c5e6d5eb61cdc0b050debbb25aae5800a3ab5b58ff946c75d63f5373fc1995f03513888d57f7ee1d63d14c2c891f23460e0a8ee642eb2'
+ '61dbab6ff60e8cd8d1d0cc724941d72af141d71ede2c690e51c495bc98f5fb804a813ac97828e6eb4de0a172970ea94b5ae430ae1242eb1c3a27e1ea9b383fdc'
'e18f2c22e394ca3b6758bc130245b254947e4d15921be3da443d6d7c3c4b0d22ead1b39fbc10a4f896edd19e2a1dffbd1cbb34dc4beb0621a6ddb70ccc53b3a7'
'877eda442eb4730600dccf209a6e961ad3122ab456bbfda4ff041e8493ebaaf96224ac218360931259ff4214482f6bf65b3a3052f977ade1a274f38ffd859535'
'87b1436052b415ab62fc0a5b53a757dd50e72e31d45a9f2031ab8ee052e93618d7108b5f5c4f9510e9f5fdc8d7577ef6ebe3788a1b3c4209b6213e16a4d8a2b3'
@@ -79,6 +81,9 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
+ # Fix build with Rust 1.48 https://bugs.archlinux.org/task/68747
+ patch -Np1 -i ../0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
+
if [ "${_modclang}" != "1" ]; then
# Apply gcc pgo patches
patch -p0 $srcdir/${pkgname}-${pkgver}/security/sandbox/linux/moz.build $srcdir/arc4_enable-lto-for-gcc.patch