summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 26 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b26558..6b0b4ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,38 @@
# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
-# Maintainer (AUR): Matt Parnell/ilikenwf <parwok@gmail.com>
+# Maintainer (AUR): Thibaut Sautereau (thithib) <thibaut at sautereau dot fr>
# # I maintain this because:
-# AUR version uses plaintext git
+# AUR version uses underscore
+# I use it and it is not in an official repo
-pkgname="hardened-malloc"
-pkgver=445+7c5c768
-pkgdesc="Hardened allocator designed for modern systems."
-url="https://github.com/GrapheneOS/hardened_malloc"
-license=("MIT")
-makedepends=("git")
-arch=("x86_64" "aarch64")
+pkgname=hardened-malloc
+_altname=hardened_malloc
+pkgver=4
pkgrel=1
-source=('git+https://github.com/GrapheneOS/hardened_malloc'
- 'preload.sh')
-b2sums=('SKIP'
- 'c8343aae044742b6a8ee50cd68125229859467be0625dae3c1bbeb91dd410b743f4771d3c2b47815c0201f6da1c652fc41840c9ada253127458851e22baeda7a')
-
-# compress the modules or not
-_compress="y"
+pkgdesc="Hardened allocator designed for modern systems"
+arch=('x86_64' 'aarch64')
+url="https://github.com/GrapheneOS/hardened_malloc"
+license=('MIT')
+makedepends=('git')
+checkdepends=('python')
+provides=('libhardened_malloc.so-64')
+conflicts=('hardened-malloc-git')
+source=("git+https://github.com/GrapheneOS/${_altname}#tag=$pkgver?signed")
+b2sums=('SKIP')
+validpgpkeys=('65EEFE022108E2B708CBFCF7F9E712E59AF5F22A') # Daniel Micay <danielmicay@gmail.com>
-pkgver() {
- cd "${srcdir}/hardened_malloc"
- printf "%s+%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+build() {
+ cd "${_altname}"
+ make
}
-build() {
- cd "${srcdir}/hardened_malloc"
-
- make
+check() {
+ cd "${_altname}"
+ make CONFIG_WERROR=false test
}
package() {
- cd "${srcdir}/hardened_malloc"
-
- mkdir -p "$pkgdir/usr/lib"
- mkdir -p "$pkgdir/usr/bin"
-
- install -D -m755 "libhardened_malloc.so" "$pkgdir/usr/lib"
- install -D -m755 "$srcdir/preload.sh" "$pkgdir/usr/bin/hardened-malloc-preload"
- install -D -m755 "calculate_waste.py" "$pkgdir/usr/bin/hardened-malloc-calculate-waste.py"
-
- msg "Done."
+ cd "${_altname}"
+ install -Dm755 --target-directory="$pkgdir/usr/lib" libhardened_malloc.so
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}