summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a84a8e9..8d1a6b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=hardened-malloc
_altname=hardened_malloc
pkgver=8
-pkgrel=1
+pkgrel=2
pkgdesc="Hardened allocator designed for modern systems"
arch=('x86_64' 'aarch64')
url="https://github.com/GrapheneOS/hardened_malloc"
@@ -17,11 +17,17 @@ depends=('gcc-libs')
makedepends=('git')
checkdepends=('python')
provides=('libhardened_malloc.so')
-options=(!makeflags)
-source=("git+https://github.com/GrapheneOS/${_altname}#tag=$pkgver?signed")
-b2sums=('SKIP')
+source=("git+https://github.com/GrapheneOS/${_altname}#tag=$pkgver?signed"
+ '0001-Fix-CPPFLAGS-in-test-Makefile.patch')
+b2sums=('SKIP'
+ '190c3eb933da1f59155ec9bde6243d8bf2eb16ed1132ce2e4a34cc3f82a92031095da158a49b822f665a71dd6445db9e9f253297fdcc20a1ab1dea189e460ecb')
validpgpkeys=('65EEFE022108E2B708CBFCF7F9E712E59AF5F22A') # Daniel Micay <danielmicay@gmail.com>
+prepare() {
+
+ patch --directory="${_altname}" --input="$srcdir/0001-Fix-CPPFLAGS-in-test-Makefile.patch" --strip=1
+}
+
build() {
cd "${_altname}"
@@ -31,8 +37,7 @@ build() {
check() {
cd "${_altname}"
- # tests fail if CPPFLAGS is not set
- CPPFLAGS="" make CONFIG_WERROR=false test
+ make CONFIG_WERROR=false test
}
package() {