summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..c1f8ec5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer: Ben Widawsky <ben@bwidawsk.net>
+# Contributor: Isaac C. Aronson <isaac@pingas.org> (original PKGBUILD)
+# Contributor: Sergio Correia <sergio@correia.cc> (modifications derived from icecream-git package)
+
+# # I maintain this because:
+# AUR version not configured for openRC
+# AUR version uses excess scripts
+
+pkgname=icecream
+pkgver=1.2
+pkgrel=9
+pkgdesc="takes compile jobs from your build and distributes it to remote machines allowing a parallel build on several machines."
+url="https://en.opensuse.org/Icecream"
+license=('GPL2')
+makedepends=('')
+depends=('bash' 'libcap-ng' 'lzo')
+provides=('icecream')
+optdepends=('iceberg-git: A Qt based monitor for icecream nodes'
+ 'ccache: ccache enabled remote builds.')
+conflicts=('icecream-git')
+backup=("etc/$pkgname.conf")
+arch=('x86_64')
+install=$pkgname.install
+source=($pkgname-$pkgver.tar.gz::https://github.com/icecc/$pkgname/archive/$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ $pkgname-scheduler.initd
+ $pkgname-scheduler.confd
+ ld-$pkgname.conf)
+sha256sums=('12d4132e5aacf6907877b691a8ac09e3e2f704ca016c49bc5eb566fc9185f544'
+ '8bacb89c6975b0f7a4411e20822d53fc2850801fb5f6ac43a0650dc245604289'
+ 'f667651facf89f01df61700f1fb7beef88ff4f330b4c7ca1b9ba9da9cfd2c463'
+ 'e65b13da1be3b4475ba765fa6dae93e009908b084d9cbc93ae2c8d4f42800ace'
+ '2bf17cc1310b55270a39179a75a0732986986e8cf271f83e70f5e74ee701ec3c'
+ '2221f16c3293dfd86e4d0442745b104380a4a1623ca3c9eb6bfe5771552fac65')
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./autogen.sh
+ ./configure --prefix=/usr/lib/$pkgname --enable-shared --disable-static --without-man
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+ install -D -m755 "$srcdir"/$pkgname-scheduler.initd "$pkgdir/etc/init.d/$pkgname-scheduler"
+ install -D -m644 "$srcdir"/$pkgname-scheduler.confd "$pkgdir/etc/conf.d/$pkgname-scheduler"
+ install -D -m755 "$srcdir"/$pkgname.initd "$pkgdir/etc/init.d/$pkgname"
+ install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir/etc/conf.d/$pkgname"
+ install -D -m644 "$srcdir"/ld-$pkgname.conf "${pkgdir}/etc/ld.so.conf.d/$pkgname.conf"
+
+ # moving pkg-config file to its usual place
+ install -D -m644 "${pkgdir}/usr/lib/$pkgname/lib/pkgconfig/icecc.pc" "${pkgdir}/usr/lib/pkgconfig/icecc.pc"
+ rm -rf "${pkgdir}/usr/lib/$pkgname/lib/pkgconfig"
+}