summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2020-01-11 15:12:44 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2020-01-11 15:12:44 -0800
commitbffb05db4cacb909bb706ff5548447863f8ee687 (patch)
treed072821c97c16ac560c81aab74bd77383a255b0c /PKGBUILD
downloadjulius-game-bffb05db4cacb909bb706ff5548447863f8ee687.tar.xz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..fbb47ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer (AUR): NiNjA <heinep at gmail dot com>
+
+# # I maintain this because:
+# AUR version lacks additional optimization and hardening flags
+
+_pkgname=julius
+pkgname=$_pkgname-game
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Open source re-implementation of Caesar III (Original copy required)"
+arch=('i686' 'x86_64')
+url="https://github.com/bvschaik/julius"
+license=('AGPL')
+makedepends=('cmake')
+depends=('sdl2' 'sdl2_mixer')
+install="$pkgname.install"
+source=($pkgname-$pkgver.tar.gz::https://github.com/bvschaik/julius/archive/v$pkgver.zip
+ $pkgname.desktop
+ $pkgname.install
+ )
+b2sums=('625bde048fbd6e7762902c8b0fecfad787f0cc6104ac441566f3e4b53935557433d932a333d4f34466730a95c02bc98f180242cee4c6b559d4275c3955b6273e'
+ '42c72e9571e84beedc41d1e263c9ed8b24366b7e163836d63847f28fa3c7b5017770bda6db350f75d45784a98123932122d5d57b82b0a96d95cc8ff57427db34'
+ 'ba7f7d492719e1f80395d1f5a5e66b0254c4fb4bbcbd2c9234b05161c16b3795f3eb2330394fb07c891389a81c575134a5bdc8ddc385be8e34f1d1516bc76221')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=4 -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=4 -fPIE"
+ export LDFLAGS="$LDFLAGS,-pie"
+
+ cmake .
+ make
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname-$pkgver/$_pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$_pkgname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm664 "$srcdir/$_pkgname-$pkgver/res/julius_48.png" "$pkgdir/usr/share/pixmaps/${pkgname}48.png"
+ install -Dm664 "$srcdir/$_pkgname-$pkgver/res/julius_256.png" "$pkgdir/usr/share/pixmaps/${pkgname}256.png"
+ install -Dm664 "$srcdir/$_pkgname-$pkgver/res/julius_512.png" "$pkgdir/usr/share/pixmaps/${pkgname}512.png"
+ install -Dm664 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}