summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5315775..3437417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,11 @@
# Arch version uses yubikey libs
# Arch version enables networking support
# Arch version enables update check
+# Arch version lacks additional optimization and hardening flags
pkgname=keepassxc
pkgver=2.4.3
-pkgrel=1.2
+pkgrel=1.3
pkgdesc="Cross-platform community-driven port of Keepass password manager"
arch=(x86_64)
url="https://keepassxc.org/"
@@ -31,8 +32,11 @@ prepare() {
build() {
cd build
- export CFLAGS="$CFLAGS -O3 -fstack-protector-all -fno-lto"
- export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -fno-lto"
+ # lto breaks compiling
+ # PIE cause the tests to fail
+ export CFLAGS="$CFLAGS -O3 -fstack-protector-all"
+ export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all"
+
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \