summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dfb7e9..85c642b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,31 @@
# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
# # I maintain this because:
+# Arch dropped kde5
# Arch version lacks additional optimization and hardening flags
-pkgname=kwin
-pkgver=5.27.10
+pkgname=kwin5
+_pkgname=kwin
+pkgver=5.27.11
_dirver=$(echo $pkgver | cut -d. -f1-3)
-pkgrel=2
+pkgrel=1
pkgdesc='An easy to use, but flexible, composited Window Manager'
arch=(x86_64)
url='https://kde.org/plasma-desktop/'
license=(LGPL)
options=(lto)
-depends=(kscreenlocker xcb-util-cursor plasma-framework5 kcmutils5 breeze
+depends=(kscreenlocker5 xcb-util-cursor plasma-framework5 kcmutils5 breeze5
pipewire-session-manager libqaccessibilityclient lcms2 libxcvt)
-makedepends=(extra-cmake-modules qt5-tools kdoctools5 krunner5 wayland-protocols plasma-wayland-protocols python)
+makedepends=(extra-cmake-modules qt5-tools kdoctools5 krunner5 wayland-protocols plasma-wayland-protocols5 python)
optdepends=('maliit-keyboard: virtual keyboard for kwin-wayland')
-replaces=(kwayland-server)
-groups=(plasma)
-source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
-install=$pkgname.install
-sha256sums=('b85a25125900b62cb5a3c609961088c45a58f55004317e4f5e8ba2039ae6dac6'
+conflicts=("$_pkgname")
+replaces=("$_pkgname")
+groups=(plasma5)
+source=(https://download.kde.org/stable/plasma/$_dirver/$_pkgname-$pkgver.tar.xz{,.sig})
+install=$_pkgname.install
+sha256sums=('8902b23b29bd54cd26590fe04abfe58fe334a5bf9c0dfd1f7dc5aacc4191b56f'
'SKIP')
-b2sums=('13da6f83e55236d7060c3f1fcf4f8e2ff5ca0351ae8c5fe6f313a4a4872430a5c049c582993d8c7817b493477f918060220b6b2ccda2baea0d44eb34767e2fc9'
+b2sums=('a21fa8d60418bf109b3f651f266185b1e97bdc92e7c7d7ab4b73271d91e8c2b629fd22851b3fff88d7ecd8277fdd8a70bf1c3bd93aa1e379377b86f56cfe2bd2'
'SKIP')
validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D' # Jonathan Esk-Riddell <jr@jriddell.org>
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
@@ -39,7 +42,7 @@ build() {
export CFLAGS="$CFLAGS -O3 -fstack-protector-all -fPIC"
export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -fPIC"
- cmake -B build -S $pkgname-$pkgver \
+ cmake -B build -S $_pkgname-$pkgver \
-DCMAKE_INSTALL_LIBEXECDIR=lib \
-DBUILD_TESTING=OFF
cmake --build build