summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61a3212..282c125 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@
# AUR version uses http
# AUR version uses unofficial repo
# AUR version needlessly purges old build folder
+# AUR version lacks additional optimization and hardening flags
pkgname=lgogdownloader
pkgver=3.7
@@ -28,6 +29,11 @@ prepare() {
}
build() {
+
+ export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=4 -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=4 -fPIE"
+ export LDFLAGS="$LDFLAGS,-pie"
+
cd $srcdir/$pkgname-$pkgver/build
make