summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD104
1 files changed, 104 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..942523b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,104 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer (Parabola): Luke Shumaker <lukeshu@parabola.nu>
+# Contributor (Parabola): Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
+# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
+# Contributor (Parabola): Márcio Silva <coadde@hyperbola.info>
+
+# # I maintain this because:
+# Required for your-freedom
+# Parabola version uses non-standard pkgver
+
+pkgbase=libretools
+pkgname=(libretools librelib gitget)
+pkgdesc="Programs for Parabola development"
+url="https://git.parabola.nu/packages/libretools.git/"
+license=('GPL3' 'GPL2')
+
+pkgver=20181004
+source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz{,.sig})
+sha256sums=('2bdefd1803ba3e6cbd1eb955fad3de9ce8a4abfd23a0bd96a60772762df7b53b'
+ 'SKIP')
+validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9') # Luke Shumaker
+
+pkgrel=1
+arch=('any')
+makedepends=(ruby-ronn)
+checkdepends=(
+ bash-bats git
+ 'pacman>=5.1.1-1' 'pacman<5.2'
+ expac
+ openssh
+ rsync
+ tokyocabinet
+)
+
+build() {
+ cd "$srcdir/$pkgbase-$pkgver"
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgbase-$pkgver"
+
+ SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
+}
+
+package_librelib() {
+ pkgdesc="The shell library portion of libretools"
+ license=(GPL2)
+ conflicts=('xbs')
+ optdepends=(
+ 'libretools: for libreblacklist/blacklist.sh'
+ 'wget: for libreblacklist/blacklist.sh'
+ )
+
+ cd "$srcdir/$pkgbase-$pkgver"
+ make install-librelib DESTDIR="$pkgdir"
+}
+
+package_gitget() {
+ pkgdesc="A simple to use downloader for git URLs"
+ license=(GPL2)
+ depends=("librelib=$pkgver" git)
+
+ provides=("libregit=$pkgver")
+ conflicts=("libregit")
+ replaces=("libregit")
+
+ cd "$srcdir/$pkgbase-$pkgver"
+ make install-gitget DESTDIR="$pkgdir"
+}
+
+package_libretools() {
+ backup=(etc/libretools.conf
+ etc/libretools.d/chroot.conf
+ etc/libretools.d/libredbdiff.conf
+ etc/libretools.d/librefetch.conf)
+ install=libretools.install
+ conflicts=(devtools libretools-mips64el)
+ replaces=(libretools-mips64el)
+
+ depends=(
+ "librelib=$pkgver"
+ "gitget=$pkgver" # `createworkdir`
+ 'pacman>=5.1.1-1' 'pacman<5.2'
+ arch-install-scripts # `mkarchroot` uses `pacstrap`
+ binutils # `libremakepkg` uses `makepkg` uses `strip`
+ expac # `libredbdiff`
+ fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
+ make # `librefetch`
+ openssh # `librerelease`
+ rsync # `librerelease` and `makechrootpkg.sh`
+ 'systemd-tools>=234' # systemd-nspawn
+ tokyocabinet # `toru`
+ #namcap # Namcap is currently dissabled in libremakepkg :-(
+ subversion # `diff-unfree`
+ wget # `aur`, optdepend for librelib:`blacklist`
+ )
+ optdepends=(
+ 'qemu-user-static-binfmt: To build ARM packages from x86'
+ )
+
+ cd "$srcdir/$pkgbase-$pkgver"
+ make install-libretools DESTDIR="$pkgdir"
+}