summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69f3367..e730223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,14 +13,19 @@ url="https://sourceforge.net/projects/lincity-ng.berlios/"
license=('GPL' 'custom')
depends=('sdl_mixer' 'sdl_ttf' 'sdl_image' 'physfs' 'libxml2' 'sdl_gfx' 'libgl')
makedepends=('ftjam' 'mesa' 'glu')
+options=('lto')
source=(https://sourceforge.net/projects/${pkgname}.berlios/files/${pkgname}-${pkgver}.tar.bz2)
b2sums=('39992e6a2ef78e53eea1b0e347c968f6828089b5267e6d62dac7405ea91b182335431b1718ef9892b649b1437751959deb9fa407dfd899fd1dfca55145d059f2')
build() {
cd ${pkgname}-${pkgver}
- export CFLAGS="$CFLAGS -O3 -flto=4 -fPIE"
- export CXXFLAGS="$CXXFLAGS -O3 -flto=4 -fPIE"
+ # Build fails due to this Werror
+ export CFLAGS="$CFLAGS -Wno-error=format-security"
+ export CXXFLAGS="$CXXFLAGS -Wno-error=format-security"
+
+ export CFLAGS="$CFLAGS -O3 -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fPIE"
export LDFLAGS="$LDFLAGS,-pie"
./configure --prefix=/usr