summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-03-23 21:10:23 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-03-23 21:10:23 -0700
commita6d4bdbc3f0bd181f1bbd1a343afa37bb2c74e07 (patch)
tree89e6cbb21c64a8c24696782a636c48f57befb6c2 /PKGBUILD
downloadlinux-ck-a6d4bdbc3f0bd181f1bbd1a343afa37bb2c74e07.tar.xz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD292
1 files changed, 292 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..875e453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,292 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
+# Maintainer (Arch): Thomas Baechler <thomas@archlinux.org>
+# Contributor: Aqua-sama <aqua@iserlohn-fortress.net>
+
+# # I maintain this because:
+# Arch version patch script does not apply consistently
+# Arch version lacks ath9k, greysky2, and raid6 patches
+# Arch version lacks ck patches
+# Arch version allows SM3 and SM4
+# Arch version is 300 Hz
+# Arch version supports Intel ME
+# Arch version is not configured for openrc
+# Arch version builds docs using python and graphviz
+# Arch version uses git
+
+pkgbase=linux-ck
+_majver=5.0
+_minver=4
+pkgver=${_majver}.${_minver}
+_ckpatchversion=1
+_ckpatch="patch-${_majver}-ck${_ckpatchversion}"
+_gcc_more_v='20180509'
+_srcname=linux-${pkgver}
+pkgrel=1
+url='https://kernel.org'
+#url='http://ck.kolivas.org/patches/'
+arch=('x86_64')
+license=('GPL2')
+makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
+conflicts=('linux-libre')
+options=('!strip')
+source=(https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz
+ https://www.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.sign
+ #http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
+ ${_ckpatch}.patch
+ enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
+ 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ 0002-netfilter-nf_tables-fix-set-double-free-in-abort-pat.patch
+ ath9k-regdom-hack.patch
+ raid6-default-algo.patch
+ config.x86_64 # the main kernel config files
+ 60-linux.hook # pacman hook for depmod
+ 90-linux.hook # pacman hook for initramfs regeneration
+ linux.preset # standard config files for mkinitcpio ramdisk
+)
+sha256sums=('8f853aa05c496e27452da5e0ca74c56fab447cb2c24f047c55fd1d13d8bdea68'
+ 'SKIP'
+ '1d8d8963d44aa8aeedc5a2ee531e197b3b51659772b871ccdd2d5dafed83f52b'
+ '226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
+ '91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
+ '87e88d199d8e9beb89d8e5f7ce6a4bf8db18ccec169323c9b6fda563719d76ba'
+ 'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
+ '0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
+ '888b73cbcfa16f1990f66b21d38d617ee884d1756cbe771c8911bd8730ff8ed1'
+ 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
+ '75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
+validpgpkeys=(
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ '8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
+)
+
+_kernelname=${pkgbase#linux}
+
+prepare() {
+ cd $_srcname
+
+# # add upstream patch
+# msg2 "Applying upstream patch"
+# patch -Np1 < ../patch-${_majver}-${_pkgver}
+
+ # Hotfixes
+ # msg2 "Applying hotfixes"
+
+ # ck patch
+ msg2 "Applying ck patch"
+ patch -p1 -i ../${_ckpatch}.patch
+
+ # graysky2 gcc patch
+ msg2 "Applying graysky2 cpu patch"
+ patch -p1 -i ../kernel_gcc_patch-${_gcc_more_v}/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
+
+ # 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+ msg2 "Applying disallow-unpriv-clone-newuser patch"
+ patch -p1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
+
+ # 0002-netfilter-nf_tables-fix-set-double-free-in-abort-pat.patch
+ msg " Applying nftables-double-free patch"
+ patch -p1 -i ../0002-netfilter-nf_tables-fix-set-double-free-in-abort-pat.patch
+
+ # Ignore ath9k eeprom patch
+ msg2 "Applying ath9k patch"
+ patch -p1 -i ../ath9k-regdom-hack.patch
+
+ # Set default raid6 algo patch
+ msg " Applying raid6 patch"
+ patch -p1 -i ../raid6-default-algo.patch
+
+
+ msg2 "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "$_kernelname" > localversion.20-pkgname
+
+
+ msg2 "Setting config..."
+ # we are in src/linux-x.yy.zz, looking for a config next to the pkgbuild
+ if [ -f ${SRCDEST}/config.ck.previous ]; then
+ cp ${SRCDEST}/config.ck.previous .config
+ else
+ cp ../config.x86_64 .config
+ fi
+
+ make olddefconfig
+
+ make menuconfig
+
+ # Remove sublevel when no sublevel exists
+ # sed -i '/SUBLEVEL = 0/d' Makefile
+
+ make -s kernelrelease > ../version
+
+ # workaround for make -s kernelrelease not applying
+ # localversion to version when changed using menuconfig
+ grep -Po '(?<=CONFIG_LOCALVERSION=").*(?=")' .config > ../localversion
+ echo "$pkgver" > ../version.temp
+ cat "localversion.10-pkgrel" >> ../version.temp
+ cat "localversion.20-pkgname" >> ../version.temp
+ cat ../localversion >> ../version.temp
+ cat ../version.temp | tr -d "\n" > ../version
+
+ # back up the config
+ msg2 "Backing up config..."
+ cp .config ${SRCDEST}/config.ck.previous
+
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+}
+
+build() {
+ cd $_srcname
+ make bzImage modules
+}
+
+_package() {
+ pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
+ [[ $pkgbase = linux ]] && groups=(base)
+ depends=(coreutils linux-firmware kmod mkinitcpio)
+ optdepends=('crda: to set the correct wireless channels of your country')
+ backup=("etc/mkinitcpio.d/$pkgbase.preset")
+ install=linux.install
+
+ local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+
+ cd $_srcname
+
+ msg2 "Installing boot image..."
+ install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+
+ msg2 "Installing modules..."
+ mkdir -p "$modulesdir"
+ make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+
+ # a place for external modules,
+ # with version file for building modules and running depmod from hook
+ local extramodules="extramodules$_kernelname"
+ local extradir="$pkgdir/usr/lib/modules/$extramodules"
+ install -Dt "$extradir" -m644 ../version
+ ln -sr "$extradir" "$modulesdir/extramodules"
+
+ # remove build and source links
+ rm "$modulesdir"/{source,build}
+
+ msg2 "Installing hooks..."
+ # sed expression for following substitutions
+ local subst="
+ s|%PKGBASE%|$pkgbase|g
+ s|%KERNVER%|$kernver|g
+ s|%EXTRAMODULES%|$extramodules|g
+ "
+
+ # hack to allow specifying an initially nonexisting install file
+ sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
+ true && install=$install.pkg
+
+ # fill in mkinitcpio preset and pacman hooks
+ sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
+ "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
+ sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
+ "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
+ sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
+ "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
+
+ msg2 "Fixing permissions..."
+ chmod -Rc u=rwX,go=rX "$pkgdir"
+}
+
+_package-headers() {
+ pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ cd $_srcname
+
+ msg2 "Installing build files..."
+ install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ install -Dt "$builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$builddir" -a scripts
+
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ if [[ -e tools/objtool/objtool ]]; then
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+ fi
+
+ # add xfs and shmem for aufs building
+ mkdir -p "$builddir"/{fs/xfs,mm}
+
+ # ???
+ mkdir "$builddir/.tmp_versions"
+
+ msg2 "Installing headers..."
+ cp -t "$builddir" -a include
+ cp -t "$builddir/arch/x86" -a arch/x86/include
+ install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+
+ install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+
+ # http://bugs.archlinux.org/task/13146
+ install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+
+ # http://bugs.archlinux.org/task/20402
+ install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+
+ msg2 "Installing KConfig files..."
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+
+ msg2 "Removing unneeded architectures..."
+ local arch
+ for arch in "$builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
+ echo "Removing $(basename "$arch")"
+ rm -r "$arch"
+ done
+
+ msg2 "Removing documentation..."
+ rm -r "$builddir/Documentation"
+
+ msg2 "Removing broken symlinks..."
+ find -L "$builddir" -type l -printf 'Removing %P\n' -delete
+
+ msg2 "Removing loose objects..."
+ find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+
+ msg2 "Stripping build tools..."
+ local file
+ while read -rd '' file; do
+ case "$(file -bi "$file")" in
+ application/x-sharedlib\;*) # Libraries (.so)
+ strip -v $STRIP_SHARED "$file" ;;
+ application/x-archive\;*) # Libraries (.a)
+ strip -v $STRIP_STATIC "$file" ;;
+ application/x-executable\;*) # Binaries
+ strip -v $STRIP_BINARIES "$file" ;;
+ application/x-pie-executable\;*) # Relocatable binaries
+ strip -v $STRIP_SHARED "$file" ;;
+ esac
+ done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
+ msg2 "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+
+ msg2 "Fixing permissions..."
+ chmod -Rc u=rwX,go=rX "$pkgdir"
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers")
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+done
+
+# vim:set ts=8 sts=2 sw=2 et: