summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-01-24 22:56:09 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-01-24 22:56:09 -0800
commit32e0a6e70403e7ffc28dd018788b3b989cd1031b (patch)
treef5590ee4209fd28c47f7f89e73d13948634bd9a3 /PKGBUILD
parentUpdated to 4.19.12.a (diff)
downloadlinux-hardened-ck-32e0a6e70403e7ffc28dd018788b3b989cd1031b.tar.xz
Updated to 4.20.4.a
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 13 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efe0eb6..9581984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,13 @@
# Arch version builds docs using python and graphviz
pkgbase=linux-hardened-ck
-_majver=4.19
-_minver=12
+_majver=4.20
+_minver=4
_pkgver=${_majver}.${_minver}
_hardenedver=a
-_NUMAdisable=y
_ckpatchversion=1
-_ckpatchname="patch-${_majver}-ck${_ckpatchversion}"
-_jcpatchversion=2
+_ckpatch="patch-${_majver}-ck${_ckpatchversion}"
+_jcpatchversion=1
_gcc_more_v='20180509'
_srcname=linux-${_pkgver}
pkgver=${_pkgver}.${_hardenedver}
@@ -42,7 +41,7 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/linux-${_pkgver}.tar.xz
# https://www.kernel.org/pub/linux/kernel/v4.x/patch-${_pkgver}.sign
https://github.com/anthraxx/linux-hardened/releases/download/${_pkgver}.${_hardenedver}/linux-hardened-${_pkgver}.${_hardenedver}.patch{,.sig}
patch-${_majver}-ck${_ckpatchversion}-jcmod${_jcpatchversion}.patch
- #http://ck.kolivas.org/patches/4.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatchname}.xz
+ #http://ck.kolivas.org/patches/4.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
ath9k-regdom-hack.patch
config.x86_64 # the main kernel config files
@@ -50,14 +49,14 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/linux-${_pkgver}.tar.xz
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('4d81ac539d62617f5b52f25971749d8c6d3a200deee76898bb99be8492999b77'
+sha256sums=('dd7fd7eafb8f94a3813a6398d5d2720422a80c933d0dc076479e5c58ecfd34d1'
'SKIP'
- 'df3b2316bfe81e702dbddccfbbd37402d592f1af80dfc90296b50ba141604b44'
+ 'b795a107eceb2fd4ab51f7a7f06f700b6f6827cca277a2d8f94be28eeeb924b4'
'SKIP'
- 'c7e090301b6fb3d6f320aeaee6747077ed616ccaf3d22d0d5937d5ea5116ffd8'
+ '90ab0d864452726a7b43f49debeb32ab4dc5d0ec65cb8b3f64c940a2469ab650'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
- '2110e5378ca3770fd0d66b916cbe1a58c135267cee41e23d0463a90a74be0b89'
+ 'bb208db0e8e419d714de529b19f2b5d57f743c56c1c1e4c241f11817d76960ec'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -79,7 +78,7 @@ prepare() {
# patch -Np1 < ../patch-${_majver}-${_pkgver}
# Hotfixes
- # msg2 "Applying hotfixes"
+# msg2 "Applying hotfixes"
# linux hardened patch
msg2 "Applying hardened patch"
@@ -113,26 +112,13 @@ prepare() {
cp ../config.x86_64 .config
fi
- ### Optionally disable NUMA for 64-bit kernels only
- # (x86 kernels do not support NUMA)
- if [ -n "$_NUMAdisable" ]; then
- msg "Disabling NUMA from kernel config..."
- sed -i -e 's/CONFIG_NUMA=y/# CONFIG_NUMA is not set/' \
- -i -e '/CONFIG_AMD_NUMA=y/d' \
- -i -e '/CONFIG_X86_64_ACPI_NUMA=y/d' \
- -i -e '/CONFIG_NODES_SPAN_OTHER_NODES=y/d' \
- -i -e '/# CONFIG_NUMA_EMU is not set/d' \
- -i -e '/CONFIG_NODES_SHIFT=5/d' \
- -i -e '/CONFIG_NEED_MULTIPLE_NODES=y/d' \
- -i -e '/# CONFIG_MOVABLE_NODE is not set/d' \
- -i -e '/CONFIG_USE_PERCPU_NUMA_NODE_ID=y/d' \
- -i -e '/CONFIG_ACPI_NUMA=y/d' ./.config
- fi
-
make olddefconfig
make menuconfig
+ # Remove sublevel when no sublevel exists
+# sed -i '/SUBLEVEL = 0/d' Makefile
+
make -s kernelrelease > ../version
# workaround for make -s kernelrelease not applying