summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-09-06 01:04:55 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-09-06 01:04:55 -0700
commit3af33ae41fa4816934bd677d4bffef53c9004d0b (patch)
treed1b62447bc70ef8e96daa710be32ba0a3c0a5d1c /PKGBUILD
parentFixed mod (diff)
downloadlinux-hardened-ck-3af33ae41fa4816934bd677d4bffef53c9004d0b.tar.xz
Updated to 4.18.6.a
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 943830c..d9f5247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,17 @@
pkgbase=linux-hardened-ck
_majver=4.18
-_minver=5
+_minver=6
_pkgver=${_majver}.${_minver}
_hardenedver=a
_NUMAdisable=y
_ckpatchversion=1
_ckpatchname="patch-${_majver}-ck${_ckpatchversion}"
-_jcpatchversion=1
+_jcpatchversion=2
_gcc_more_v='20180509'
_srcname=linux-${_pkgver}
pkgver=${_pkgver}.${_hardenedver}
-pkgrel=2
+pkgrel=1
conflicts=('linux-libre-hardened-ck')
url='https://github.com/anthraxx/linux-hardened'
#url='http://ck.kolivas.org/patches/'
@@ -41,21 +41,23 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/linux-${_pkgver}.tar.xz
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
- increase-timeout-in-lspcon_wait_mode.patch
+ drm-i915-Increase-LSPCON-timeout.patch
+ HID-core-fix-grouping-by-application.patch
)
-sha256sums=('fb090a3680eddf6f10bf895bc3075bd3f830e3d2429ce469982db5a28df647bd'
+sha256sums=('05db97fd6891217af6d4203bdc442ef2af78d7902b6a8e9bd348682704c22894'
'SKIP'
- 'a06238ea0ce66d090fa899d6951c9d40fa993c7b4975088dded2c1e660c1ff69'
+ 'd3a244e228a566d536a26fcfe57252bb6e9b61c0f070ef4bb9eaad868196bef3'
'SKIP'
- 'f00cfe3d497254853793d3aa751f5d19d81ced54504a56f247c03908eee230d1'
+ 'cb33bfe492aeef9b1fda8d448483a7ef3d3fe27448e2114a775b25beb1bd8830'
'6e1f3cc3eb9a1e30a69ef1999f9aa6ad7f2f9fe4af7ba5dabe25d4ff19ee6740'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
- '830db84d2fcb113a1bba8519fb0855f241d771ea10e4b4d0707cdc1583697420'
+ 'a931a1f073deada7c51ae54d8a12b3fc49c2f0b6b6bc5b6673bf634ec6f0e025'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '0fa6899b57d32988b70050f1a67f435936273ce1aa98575271d564ccfaf45f77')
+ '2f26b6273ded6d4031fd7115fac843b7bb90df9a28da8dc1b7f49294d3d39ee7'
+ '472f606f043b16336f5335021285efe3a7658fb8467917409cb58c9a57a7b0a5')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -71,11 +73,12 @@ prepare() {
# # add upstream patch
# msg2 "Applying upstream patch"
-# patch -Np1 < ../patch-${_gnumajver}-${_gnupkgver}
+# patch -Np1 < ../patch-${_majver}-${_pkgver}
# Hotfixes
msg2 "Applying hotfixes"
- patch -p1 -i ../increase-timeout-in-lspcon_wait_mode.patch
+ patch -p1 -i ../drm-i915-Increase-LSPCON-timeout.patch
+ patch -p1 -i ../HID-core-fix-grouping-by-application.patch
# linux hardened patch
msg2 "Applying hardened patch"