summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6f08b5..0391639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,6 +44,8 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz
ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch
# https://bugs.archlinux.org/task/56711
Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
+ # Fix iwd provoking a BUG
+ mac80211-disable-BHs-preemption-in-ieee80211_tx_cont.patch
)
sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
'SKIP'
@@ -54,12 +56,13 @@ sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
'27b96297102a9ccf690c1bdc5f21bc10308f6de90396385dce7341fb8e5a2116'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
- '796fc70dbad0211fc3de86203efdb4bbbdfe082da98e7891aaf8869cef57cb8d'
+ '5b72267157627aeb77b76494ed5dd13df9c67c87dbd75a82cace78ef5e03d6ed'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'd744e7f4552896670bc8b99361534eec7ba095bebc2462ef0e5ee433e6341a0a'
- '8114295b8c07795a15b9f8eafb0f515c34661a1e05512da818a34581dd30f87e')
+ '8114295b8c07795a15b9f8eafb0f515c34661a1e05512da818a34581dd30f87e'
+ 'ef7c149d9af24efea551cec86e26f52c9c1cc02714335e948f929985ff414676')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -80,6 +83,7 @@ prepare() {
msg2 "Applying hotfixes"
patch -p1 -i "${srcdir}/ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch"
patch -p1 -i "${srcdir}/Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch"
+ patch -p1 -i "${srcdir}/mac80211-disable-BHs-preemption-in-ieee80211_tx_cont.patch"
# fix naming schema in EXTRAVERSION of ck patch set
#sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatchname}"
@@ -157,7 +161,7 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
- [ "${pkgbase}" = "linux-hardened" ] && groups=('base')
+ [ "${pkgbase}" = "linux" ] && groups=('base')
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")