summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53c0072..044bb33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,14 @@
# Arch version supports Intel ME
pkgbase=linux-hardened-ck
-_majver=4.18
-_minver=20
+_majver=4.19
+_minver=4
_pkgver=${_majver}.${_minver}
_hardenedver=a
_NUMAdisable=y
_ckpatchversion=1
_ckpatchname="patch-${_majver}-ck${_ckpatchversion}"
-_jcpatchversion=2
+_jcpatchversion=1
_gcc_more_v='20180509'
_srcname=linux-${_pkgver}
pkgver=${_pkgver}.${_hardenedver}
@@ -39,7 +39,6 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/linux-${_pkgver}.tar.xz
# https://www.kernel.org/pub/linux/kernel/v4.x/patch-${_pkgver}.sign
https://github.com/anthraxx/linux-hardened/releases/download/${_pkgver}.${_hardenedver}/linux-hardened-${_pkgver}.${_hardenedver}.patch{,.sig}
patch-${_majver}-ck${_ckpatchversion}-jcmod${_jcpatchversion}.patch
- Fix_MuQSS_full_dynticks_build.patch::https://github.com/ckolivas/linux/commit/abb4fd30fa127a0e8178b975343eb01713bc2b18.patch
#http://ck.kolivas.org/patches/4.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatchname}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
ath9k-regdom-hack.patch
@@ -48,15 +47,14 @@ source=(https://www.kernel.org/pub/linux/kernel/v4.x/linux-${_pkgver}.tar.xz
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
)
-sha256sums=('68ac319e0fb7edd6b6051541d9cf112cd4f77a29e16a69ae1e133ff51117f653'
+sha256sums=('a38f5606bba1f5611c798541f6c3d43267b8599d9e3167471d4b662e33ff47aa'
'SKIP'
- '225e672f2c00a6b4e9b5e03900baa276392454ca1ed7c800180e1c4eabb9330c'
+ '2779c1dc568958f54b012c5bef9e1e6e0bc714e02910e831a916c5f4d2ad43ce'
'SKIP'
- 'cb33bfe492aeef9b1fda8d448483a7ef3d3fe27448e2114a775b25beb1bd8830'
- '6e1f3cc3eb9a1e30a69ef1999f9aa6ad7f2f9fe4af7ba5dabe25d4ff19ee6740'
+ 'ace81dad929001a441c028974e1bb014bacabc39d8311efd944fb087dab1436a'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
- '4b34927652a8ea9e5fe47a3b06b4fa226dc1efd8f3992fd679152f90bb5e77e5'
+ '2e22225a6f62ea40ac30c08e49e3b4fe36a25f5f3df0561ae89a994009899a30'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -96,10 +94,6 @@ prepare() {
msg2 "Applying ck patch"
patch -p1 -i ../patch-${_majver}-ck${_ckpatchversion}-jcmod${_jcpatchversion}.patch
- # ck hotfix
- msg2 "Applying ck Fix_MuQSS_full_dynticks_build hotfix"
- patch -p1 -i ../Fix_MuQSS_full_dynticks_build.patch
-
msg2 "Setting version..."
sed -e "/^EXTRAVERSION =/s/=.*/= .${_hardenedver}/" -i Makefile
@@ -162,12 +156,16 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ # ln -sr "$image" "$modulesdir/vmlinuz"
# a place for external modules,
# with version file for building modules and running depmod from hook