summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 979e517..033f095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# # I maintain this because:
# Arch version patch script does not apply consistently
-# Arch version lacks ath9k, greysky2, and raid6 patches
+# Arch version lacks ath9k, bdver2, greysky2, and raid6 patches
# Arch version lacks ck patches
# Arch version allows SEED, SM3, SM4, and Streebog
# Arch version is 300 Hz
@@ -17,7 +17,7 @@
pkgbase=linux-hardened-ck
_majver=5.0
-_minver=7
+_minver=10
_pkgver=${_majver}.${_minver}
_hardenedver=a
_ckpatchversion=1
@@ -33,30 +33,33 @@ license=('GPL2')
makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
conflicts=('linux-libre-hardened-ck')
options=('!strip')
-source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-$_pkgver.tar".{xz,sign}
+source=(
+ https://www.kernel.org/pub/linux/kernel/v5.x/linux-$_pkgver.tar.{xz,sign}
https://github.com/anthraxx/linux-hardened/releases/download/${pkgver}/linux-hardened-${pkgver}.patch{,.sig}
remove-excess-ck-extraversion.patch
modify-ck-for-hardened.patch
http://ck.kolivas.org/patches/5.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
+ bdver2-fix-for-graysky.patch
ath9k-regdom-hack.patch
raid6-default-algo.patch
config.x86_64 # the main kernel config files
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
-)
-sha256sums=('16e177662b9fc7255bfc51018513979f6effcbe52e459c543aa83a5b15ef54ec'
+ )
+sha256sums=('ea1c1323c2c7e70bebf5463619b543f9bc353730b44ac62d9efadd4fe5625e76'
'SKIP'
- '250494afb2dce0c4805223b32a3abad2c146d628c7b972c361ae3e7fa3ea8ee6'
+ 'da6aff1ea5e2c39987fea2fc5a67b7ef5419a6ba9ed728c94f89ce888b543a12'
'SKIP'
'2a551169f8cbb424900372fe698ae9003fbcad3614a46ca3f56b103f9c1ea763'
'b6defd1ef672b73631ecfa79fc204d6219175f333b53d86af668c1e1a9b6288e'
'661f64bbd8bf49afcc7c760c4148b2e2108511a1eadcae917cfe6056a83d8476'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
+ 'd35338c92d0dbf27ffedaf100bd852dd13fd9b5d49b12a10b91194a2ae654447'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
'0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
- 'ac3205c67d310da26a03e84874012113fdd4c128ab79449bafd3d248f30365df'
+ '2cfaad4fccd60af062761bba0549f817d2d7efe0c603c529c9b5b2f8bbb9f011'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
@@ -77,7 +80,7 @@ prepare() {
# patch -Np1 < ../patch-${_majver}-${_pkgver}
# Hotfixes
-# msg2 "Applying hotfixes"
+ # msg2 "Applying hotfixes"
# linux hardened patch
msg2 "Applying hardened patch"
@@ -97,12 +100,16 @@ prepare() {
msg2 "Applying graysky2 cpu patch"
patch -p1 -i ../kernel_gcc_patch-${_gcc_more_v}/enable_additional_cpu_optimizations_for_gcc_v8.1+_kernel_v4.13+.patch
+ # Fix stack warnings and ldconfig segfaults on bdver2 with graysky2 gcc patch
+ msg2 "Applying bdver2 fix for graysky2 cpu patch"
+ patch -p1 -i ../bdver2-fix-for-graysky.patch
+
# Ignore ath9k eeprom patch
msg2 "Applying ath9k patch"
patch -p1 -i ../ath9k-regdom-hack.patch
# Set default raid6 algo patch
- msg " Applying raid6 patch"
+ msg2 " Applying raid6 patch"
patch -p1 -i ../raid6-default-algo.patch