summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-02-18 08:00:42 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-02-18 08:00:42 -0800
commit27b92b614d57caaa317fdf36a561d364843d90e6 (patch)
tree359f63b3683cfc9a31b7f7ddfc121fdded070a90 /PKGBUILD
parentUpdated to 4.20.7.a (diff)
downloadlinux-libre-hardened-ck-27b92b614d57caaa317fdf36a561d364843d90e6.tar.xz
Updated to 4.20.10.a
- Added raid6 preselected algorithm patch. Anyone that uses raid6 and has avx2 should change it to avx2x4. - Disabled radeon and amdgpu as they depend on non-free firmwares. Disabled all wifi drivers that depend on non-free firmwares.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e318603..cba37e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,18 @@
# # I maintain this because:
# Parabola version patch script does not apply consistently
-# Parabola version lacks ck ath9k and greysky2 patches
+# Parabola version lacks ath9k, greysky2, and raid6 patches
+# Parabola version lacks ck patches
# Parabola version allows SM3 and SM4
# Parabola version is 300 Hz
# Parabola version supports Intel ME
# Parabola version is not configured for openrc
# Parabola version builds docs using python and graphviz
# Parabola version is out-of-date
-# Parabola version disables modules for components that lack free firmware
pkgbase=linux-libre-hardened-ck
_majver=4.20
-_minver=7
+_minver=10
_pkgver=${_majver}.${_minver}
_gnumajver=${_majver}-gnu
_gnupkgver=${_pkgver}-gnu
@@ -45,24 +45,28 @@ source=(https://linux-libre.fsfla.org/pub/linux-libre/releases/${_gnumajver}/lin
#http://ck.kolivas.org/patches/4.0/${_majver}/${_majver}-ck${_ckpatchversion}/${_ckpatch}.xz
enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz
ath9k-regdom-hack.patch
+ raid6-default-algo.patch
config.x86_64 # the main kernel config files
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
linux.preset # standard config files for mkinitcpio ramdisk
+ unscrew-ck1-for-kvm-intel-symbol.patch
)
sha256sums=('b80d5c0076dfa11ee8af63ad0b4795569d098b77020d2fffc797b892ba455a1f'
'SKIP'
- '5913cc1dd4c94446cebc2d2bc315c888a62713380ceaa1b7982e2d848a3180b6'
+ '136328e82e21b51388eb2e5b169cf62d361abf0508d313b83b511bc048d32fb2'
'SKIP'
- '453b05f141632791f758e3334cdc542fe70506fb740a4bedc0a6013a7f55c723'
+ '12ae9028543b25f77317cb85e20554b8cc9ca0df84440d8edd7a3241703a4889'
'SKIP'
'90ab0d864452726a7b43f49debeb32ab4dc5d0ec65cb8b3f64c940a2469ab650'
'226e30068ea0fecdb22f337391385701996bfbdba37cdcf0f1dbf55f1080542d'
'e7ebf050c22bcec0028c0b3c79fd6d3913b0370ecc6a23dfe78ce475630cf503'
- '739a998db99184637da986ed4e694012e982e883e9e688882e25d2e6c3461765'
+ '0f81d6e4158b7beeb0eb514f1b9401f7e23699cb0f7b0d513e25dae1815daaeb'
+ '602bb69819223506182319df69ca13828b9ef0a436e09903e81987c30cf19dcd'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
- 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65')
+ 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
+ '3e8c7d3015bb593e8a861be0b2b9f1de74fcb25e00c6e3eacee3165c6bec6f64')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'65EEFE022108E2B708CBFCF7F9E712E59AF5F22A' # Daniel Micay
@@ -94,10 +98,18 @@ prepare() {
msg2 "Applying ath9k patch"
patch -p1 -i ../ath9k-regdom-hack.patch
+ # Set default raid6 algo patch
+ msg " Applying raid6 patch"
+ patch -p1 -i ../raid6-default-algo.patch
+
# ck patch
msg2 "Applying ck patch"
patch -p1 -i ../patch-${_majver}-ck${_ckpatchversion}-jcmod${_jcpatchversion}.patch
+ # Set unscrew patch
+ msg " Applying unscrew patch"
+ patch -p1 -i ../unscrew-ck1-for-kvm-intel-symbol.patch
+
msg2 "Setting version..."
sed -e "/^EXTRAVERSION =/s/=.*/= .${_hardenedver}/" -i Makefile