summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dea19f3..c61f608 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ _pkgbase=linux-hardened
pkgbase=linux-libre-hardened
_supver=5
_majver=7
-_minver=7
+_minver=8
_hardenedver=a
_gccpatchver='20200615'
_gccpatchger='10.1'
@@ -49,8 +49,8 @@ source=(
https://linux-libre.fsfla.org/pub/linux-libre/releases/${_gnumajver}/linux-libre-${_gnumajver}.tar.xz{,.sign}
https://github.com/anthraxx/${_pkgbase}/releases/download/${pkgver}/${_pkgbase}-${pkgver}.patch{,.sig}
0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
- 0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
- 0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
+ 0003-Revert-ath9k-Fix-general-protection-fault.patch
+ 0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
raid6-default-algo.patch
@@ -64,16 +64,19 @@ validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'E240B57E2C4630BA768E2F26FC1B547C8D8172C8' # Levente Polyak
)
-b2sums=('921a3836ffbd5ababb897b8d923ab3e97c10c39b8d01060fe41742005f8111b5c2c9e76c9b7bcf4fe59a056454a364eca5df8006ca8a174205df152007e18dff'
+b2sums=('bb65e65c69d1c38943327a0859028c843439590e9f1af66705a0fe01aaf006daf14a5a0adfaef6d1de53511e50b2f6b8ee13caa63dd7cf4065253599fe524998'
'SKIP'
- '9ca983d083d226b8a68079a72c98bc421f3cdc7b97faf478fd2de451b7f66cfff2ff5c468394bdbfc06a5f4baf93ec926e26c9ff1dc3a8c8108855ca2d6ca910'
+ '7d2fef10b36c6a102959865eeeaeffa7a87a664812924fe76ea2c375e6954b4e982411f51408be4757df4e887b7db38fd8cb615e2b6c2e4ab11fa32d603319c3'
'SKIP'
+ '490c7d188215f1d24b5807a744853fa308c2cd17c9eb8668918a50a0c58cab9cbc9ee13ac9abbb614eb010a4a56e9092fea4440d44c80c8e67f2d9abdf19a83f'
+ '35b1ace7c6d9f1c78caf6007d5500d1c5762af887cd45fddb4d32fcc289c0e0ad62473417ba4cd617f2632533a85ecadd08556cb6c106e06686cd53cc018bbef'
+ 'a0f3b060d344746d7cd02b9b8b0f6e13a4367d41aa92ef7db4b6d01d2a0389b63da3e19484ac809952ef6ee13479a54ad205017c9ead72c4ee6738ae04cb7c4b'
'c8d0697f99fe6105815217b8ec059d8f587415ea8dd2b88a65e1087feedf697341a64cd56810fde9e7aeada79125fc8235faccc7e7b06492c099e27a8abbe99c'
'2e58bb89b247b1678355368956e67c1de51fcde97a227b2162f6771e30f17fa5520faafe7be4b6816a542e7ae10d05f64c6b6354f352c12746d4b8da632936dd'
'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- 'be6ce87746752a05eec4c8b62453ebbb5be304ea92e76b8f33f6dd2610bd5dc11adc4b9458784fb4ff712e7c17b3c4dd0751d54f07e6f23caccacb685f3496b6'
+ '004fa374633e14c649d07ed1f190316f4c0d2cd8d5b2b2480fdf8b0f635339b3638eb4f5d3a407fd1af60e876416a89382747008eef1c7e3188d1bc2eb6fd3d2'
'b4e1377d97ad7e8144d6e55b6d43731e3271a5aec65b65ca6d81026a95f15f549b9303fb3c6f492099ca691e3f65f4cf7f0c3aa742df03b396d7f6d81813aa95'
- 'f19032b7b4e99047268f155050857cda001c5e0f50b6fd13adb2d64501ade4d4086f0896ea86dbe21c1ef8f1ee902dd07b8497ad7a2e413377cb08c8e2f021e9'
+ 'bf785bba732d54dc7e7250f1e90944237ed408828e40f32e2342adce93c9b0eee9718e5ecec6f4eab3b960cf406fbed03a8cfc59b1112ff5b387be0751330b42'
'SKIP')
export KBUILD_BUILD_HOST=$pkgbase
@@ -93,8 +96,8 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0002-PCI-EDR-Log-only-ACPI_NOTIFY_DISCONNECT_RECOVER-even.patch
- patch -p1 -i ../0003-ALSA-usb-audio-Fix-packet-size-calculation.patch
- patch -p1 -i ../0004-drm-amd-display-Only-revalidate-bandwidth-on-medium-.patch
+ patch -p1 -i ../0003-Revert-ath9k-Fix-general-protection-fault.patch
+ patch -p1 -i ../0004-iwlwifi-Make-some-Killer-Wireless-AC-1550-cards-working-again.patch
patch -p1 -i ../sphinx-workaround.patch
@@ -129,7 +132,7 @@ prepare() {
# if [ -f ${SRCDEST}/config.libre-hardened.previous ]; then
# cp ${SRCDEST}/config.libre-hardened.previous .config
# else
- cp ../config .config
+ cp --reflink ../config .config
# fi
make olddefconfig
@@ -205,7 +208,7 @@ _package-headers() {
localversion.* version vmlinux
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
- cp -t "$builddir" -a scripts
+ cp --reflink -t "$builddir" -a scripts
# add objtool for external module building and enabled VALIDATION_STACK option
if [[ -e tools/objtool/objtool ]]; then
@@ -216,8 +219,8 @@ _package-headers() {
mkdir -p "$builddir"/{fs/xfs,mm}
echo "Installing headers..."
- cp -t "$builddir" -a include
- cp -t "$builddir/arch/x86" -a arch/x86/include
+ cp --reflink -t "$builddir" -a include
+ cp --reflink -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h