summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD72
1 files changed, 39 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1e33f8..10d7bc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@
pkgbase=linux-libre
_supver=5
-_majver=10
-_minver=16
+_majver=11
+_minver=0
_gccpatchver='20201113'
_gccpatchger='10.1'
_gccpatchker='5.8'
@@ -31,7 +31,7 @@ arch=(x86_64)
license=(GPL2)
makedepends=(
bc kmod libelf pahole cpio perl tar xz
-# xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
)
conflicts=('linux')
options=('!strip')
@@ -41,8 +41,11 @@ _gnupkgver=${pkgver}-gnu
source=(
https://linux-libre.fsfla.org/pub/linux-libre/releases/${_gnumajver}/linux-libre-${_gnumajver}.tar.xz{,.sign}
config # the main kernel config file
+ sphinx-workaround.patch # Sphinx 3.5 broke the build again
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
+ 0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch
+ 0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
+ 0004-drm-amdgpu-fix-shutdown-with-s0ix.patch
kernel_gcc_patch-${_gccpatchver}.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/${_gccpatchver}.tar.gz
ath9k-regdom-hack.patch
raid6-default-algo.patch
@@ -53,16 +56,17 @@ source=(
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
)
-b2sums=('86103699a6bc906e85429430df098b0ddb7cfc8c887f98b37f994498388d634554e119eadb1b15f591bdf4f463e7efb7420e3e370af0029b7ed9e988a5f26b01'
+b2sums=('bdecaaf3c3684ab8fd92f4c5a8a85c6abb6e8a11dca2d07fb91baa1d36611ad2493627c5a6576e6db6ae52317bbbb38a134892fd48ebb8fe0386ba9f401768d3'
'SKIP'
- 'af2691c573f03530fbd0eb0700879031ca4e6e07140673c9dadd0690f59fb26846add66c36aa5d2c466968cff75eb16d13cb8927a812711724e4eebbb5dda056'
+ 'a87284197631233c3de130f349c9a89f5d08d1595c5dcbb1ee2b1ff90f5de36d6cd89c4238375126978bad5fad6d2de049b848f2caf0ab48c8d530e96a61081a'
+ 'db64b425139c107c69f44624901ae50b5e604d4c9fdfe84f78c298f8ed7a7739033a72ec678c5c3c0e82e59809d97799d0c25f96c64ef5ae79910cb890fc7bfb'
'2f9195675270d79d735a3aaec25887c2f80b76eae98be8fcc5fd59ab71d925c5ee20ec5e2a015deb68b61bc2cc7f56f546a22cb96ee038e2e24c2c9dd5c3f79f'
- 'd8297e09f552a2d6bb24c2ba10481fd2b407057f3b24278e72a89233473460d339c83838791989773623178b5af80588fb4c484da2931f1040e313cce7ceca00'
+ 'ee2176084665f1a5f1999157cb128c8c68c113b5d22c4d72bec689123493d7a9b246e1c7cff7d6ff4bba8d5c5624b4dc75f2274db941e9b3d352e41fbad86927'
+ '1e3a9aadc3e944afd9601457f69218fd4cf61badabed6924622bce3273c2a95602fc6aab00c1399767f5115d3fbecde391b553acc259c817f8d6b29a18b1f8ad'
+ 'a5c4d1bf3b15e3ee2491f75485627ebf1a9f6759f38798c08fcd09bf90b40fed997d7f14190809f4e676907f8a1c9150e3de2da856c8b92e022d3250a86040fe'
'7f1eb5938472f57748216bd00e0c875feab99fc1c5cb89babfea467ee30ca5c8e9fc5a691efe2e602bef1ea79820c5383822d7cec354b48d23321ccda8ee8127'
'b6ef77035611139fa9a6d5b8d30570e2781bb4da483bb569884b0bd0129b62e0b82a5a6776fefe43fee801c70d39de1ea4d4c177f7cedd5ac135e3c64f7b895a'
- 'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a'
- '0b54ec87bcc287cc9af09e296b233695f329edade78eac0faf9a42969e82a61c3d212f3c98836b7d1a5a48caa74cfa6192ce651b00d5bddbf1c8bc3d49d031bd'
- 'SKIP')
+ 'fde132f3705d908e6f2147c78a2193289916d72304ca5efa2229d79fc3e57a857314ce94e71425caef2f7f7b6cf87f05ef86335dc8bd4be78e7035afe608005a')
export KBUILD_BUILD_HOST=arc4linux
export KBUILD_BUILD_USER=$pkgbase
@@ -84,7 +88,10 @@ prepare() {
# Hotfixes
echo "Applying hotfixes"
patch -p1 -i ../0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- patch -p1 -i ../0002-HID-quirks-Add-Apple-Magic-Trackpad-2-to-hid_have_special_driver-list.patch
+ patch -p1 -i ../0002-Bluetooth-btusb-Some-Qualcomm-Bluetooth-adapters-stop-working.patch
+ patch -p1 -i ../0003-Revert-drm-amd-display-reuse-current-context-instead-of-recreating-one.patch
+ patch -p1 -i ../0004-drm-amdgpu-fix-shutdown-with-s0ix.patch
+ patch -p1 -i ../sphinx-workaround.patch
# graysky gcc patch
@@ -146,7 +153,7 @@ prepare() {
build() {
cd $_srcname
make all
- #make htmldocs
+ make htmldocs
}
_package() {
@@ -256,27 +263,26 @@ _package-headers() {
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
-#_package-docs() {
-# pkgdesc="Documentation for the $pkgdesc kernel"
-#
-# cd $_srcname
-# local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-#
-# echo "Installing documentation..."
-# local src dst
-# while read -rd '' src; do
-# dst="${src#Documentation/}"
-# dst="$builddir/Documentation/${dst#output/}"
-# install -Dm644 "$src" "$dst"
-# done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
-#
-# echo "Adding symlink..."
-# mkdir -p "$pkgdir/usr/share/doc"
-# ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
-#}
-
-#pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
-pkgname=("$pkgbase" "$pkgbase-headers")
+_package-docs() {
+ pkgdesc="Documentation for the $pkgdesc kernel"
+
+ cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ echo "Installing documentation..."
+ local src dst
+ while read -rd '' src; do
+ dst="${src#Documentation/}"
+ dst="$builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
+
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")