summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc0a43b..a2a50d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,13 @@
pkgname=mupen64plus-qt
pkgver=1.15
-pkgrel=3
+pkgrel=3.2
pkgdesc="A customizable launcher for Mupen64Plus"
arch=('i686' 'x86_64')
url="https://github.com/dh4/mupen64plus-qt"
license=('BSD')
-depends=('quazip' 'mupen64plus' 'hicolor-icon-theme')
+depends=('quazip-qt5' 'mupen64plus' 'hicolor-icon-theme')
+options=('lto')
install=mupen64plus-qt.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dh4/${pkgname}/archive/${pkgver}.tar.gz"
"quazip-fix.patch")
@@ -28,8 +29,8 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$pkgver"
- export CFLAGS="$CFLAGS -O3 -flto=auto -fPIE"
- export CXXFLAGS="$CXXFLAGS -O3 -flto=auto -fPIE"
+ export CFLAGS="$CFLAGS -O3 -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fPIE"
export LDFLAGS="$LDFLAGS,-pie"
qmake-qt5