summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b85ba00..d858185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,29 @@
pkgname=mupen64plus-qt
pkgver=1.14
-pkgrel=1.4
+pkgrel=2
pkgdesc="A customizable launcher for Mupen64Plus"
arch=('i686' 'x86_64')
url="https://github.com/dh4/mupen64plus-qt"
license=('BSD')
-depends=('quazip-legacy' 'mupen64plus' 'hicolor-icon-theme')
+depends=('quazip' 'mupen64plus' 'hicolor-icon-theme')
install=mupen64plus-qt.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dh4/${pkgname}/archive/${pkgver}.tar.gz")
-b2sums=('f81681861de61db9e68eb80941e97644a2e903b221c470e981c9e7f39e3cc720f59e57a08a7d5346b99ae963d6639c275c98f6519df9a203b0aaf567e9169451')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dh4/${pkgname}/archive/${pkgver}.tar.gz"
+ "quazip-fix.patch")
+b2sums=('f81681861de61db9e68eb80941e97644a2e903b221c470e981c9e7f39e3cc720f59e57a08a7d5346b99ae963d6639c275c98f6519df9a203b0aaf567e9169451'
+ '8c312e5fe002bca6194ece5638ac2b80e3b3d7da23e6594aade37f1952981ae4874f92ce55f1b54ff122514de6070d25af99ec365d382ec04551d941950e0fc1')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -Np1 -i "$srcdir"/quazip-fix.patch
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
- export CFLAGS="$CFLAGS -O3 -flto=4 -fPIE"
- export CXXFLAGS="$CXXFLAGS -O3 -flto=4 -fPIE"
+ export CFLAGS="$CFLAGS -O3 -flto=auto -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -flto=auto -fPIE"
export LDFLAGS="$LDFLAGS,-pie"
qmake-qt5
@@ -28,6 +36,7 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
+
install -Dm755 "mupen64plus-qt" "$pkgdir/usr/bin/mupen64plus-qt"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "resources/mupen64plus-qt.desktop" "$pkgdir/usr/share/applications/mupen64plus-qt.desktop"